Bad app? sketchup pro 2019

I tried downloading a mesh app in the 2019 sketchup pro that I had in the 2018. it’s not compatible and I get an error message. I’ve disabled/uninstalled app and I kept getting the message. I removed sketchup 2019 from my laptop. I reinstalled it and the message is still there???

Error Loading File Cadman_MeshWrapper.rb
Error: #<SyntaxError: C:/Users/pasca/AppData/Roaming/SketchUp/SketchUp 2019/SketchUp/Plugins/Cadman_MeshWrapper.rb:56: Invalid return in class/module body
return UI.messagebox("MeshWrapper t…

I need help please.

i’m good. i fixed it.


Try to be better snd explain how you did it😃

The error is in C:/Users/pasca/AppData/Roaming/SketchUp/SketchUp 2019/SketchUp/Plugins/Cadman_MeshWrapper.rb
line# 56 [there might be others]
The latest version’s Ruby fails if there’s a return placed directly inside a class/module incorrectly, rather than inside a nested def method etc: older Ruby versions simply ignored the error !
If you edit the file using a plain-text editor like Notepad++ and look at that line, then it probably has return somewhere in it - you curtailed the error report’s text just as it got interesting…
Add a # at the start of the line to stop the line’s code loading.
Save the change and restart SketchUp, if there are other lines with errors, note the line number and repeat the process for that line…
If you get in touch with the author of the RB file directly he might fix it and republish ?