Axes reappearing when exporting PNG (2D)


I haven’t used Sketchup in a couple of months, and now I’ve discovered I can no longer export 2D images with the axes and guides off. I have them turned off by default, but now when I go to export an image they come back back on and appear in the exported image as well as onscreen.

This is occurring across different browsers and different models — is it a new fact of life in Sketchup Free 2019, or is there something I can do to prevent it happening?

Thanks for any help you can give!

You did notice a change we just made so that people could have the option of exporting an image with or without the axes. (Before we did this, you could only export images without the axes).

To export (or print) an image without the axes, you’ll need to save a scene using a style that is edited to have the axes turned off. Then, go to export and image and pick that scene.

It does sound like a bug for the preview to override your style settings, though: so, if you have already turned off the axes, the preview shouldn’t turn them back on. I’ll look into this.

Hope this helps!


1 Like

This started happening just a few days ago. I am unable to turn off the axes. It stays off until I go to “Export”, then the axes come back on, and stay on. Sounds like a bug.

Did you do as Mark directed? It’s not a bug. It’s a change in the way things work.

Yes I saw that message, and tried to save it as a scene with the axes turned off. Except, the properties under the scene do not have the option of turning off the axes. I can only turn it off globally, but it comes right back on when I go to export as PNG.

I just tried, and it is trickier than I expected. Whether axes are showing is a Style setting, and it’s the Style that you save for a given scene.

I realized later that I had tested in SketchUp Pro, but it works the same in the web version. You go to display to turn off axes, then into Views to create a scene, then the export preview has now axes, nor does the exported png. So, however it used to work, it matches the desktop app now.

Thanks for the information!
Unfortunately, very few of the styles available in the free version have axes turned off and those that do don’t support materials, so this isn’t a workable solution for me but hopefully it will help others.

Thanks for calling this out, @DepotComms. You’re right that not many default styles have axes toggled off, so I think this is something we can sharpen up. The idea was to make the preview as WYSIWIG (what you see is what you get) as possible, but we should take into account that many people don’t want to see axes in their output.

Thanks for being so responsive!

Hi @DepotComms

We’re not quite to the bottom of this yet, but I have been able to reliably produce a simple workaround. When you’re ready to export an image (or print), turn off the Axes in your display settings, then create a scene (you’ll be prompted to update the style or create new one. You can do either). Now, when you go to export an image, you should see what you want in the preview, and be able to jump to the scene you’ve saved.

Let me know if that works for you!


This works great! Thanks a lot.

@Mark another related annoyance in the free web version is the inability to view anything in Monochrome. You have to upgrade so you can edit a style which then allows you to choose Monochrome.
The only way to get a monochrome view that I can find is to go through and repaint all faces, both back and front, with no material.
There should be a setting in views for Monochrome.

1 Like

Hey @Box, thanks for calling this out. Broadly, I agree with you. The display settings panel in SketchUp for Web is a relatively new concept and I think we are missing a few things. Monochrome face style is one, and Xray is another, in my opinion.

X-ray is possible in Free but Not Monochrome. X-ray, Hidden Line, Wireframe, etc are all there because there is a default style for each, but not Monochrome.

Seems like that ought to be an easy addition to the Default styles.