Apply texture on stretched surface

sketchup
advice

#1

Hi, how to resolve the problem with applying texture on stretched surfaces without rebuilding.


Can Someone Help Me Texture a Complex Chair with Rattan?
#2


#3

the problem is that:

  1. i cant see “position texture” selection on right click. In which situation does this happen?
  2. why when i aply new texture it get stretched?

#4

You only see a Texture… submenu in the context-menu when there is a selected face [which has a textured-material].
If you have applied the textured material onto a ‘container’ [i.e. a group or component], then it cannot be modified using Texture…
If it’s a ‘container’ then select it and in Entity Info reset its material to the default-material.
Now edit the ‘container’.
Check that its faces are properly oriented - View > Monochrome mode with a distinctive back-face color - if there are reversed faces, then select them and context-menu 'Reverse…'
Now paint the required textured-material onto the faces.
Use the context-menu Texture toolset to position/rotate etc as desired…
If you want to copy a particular texture’s set up onto another face you can use the Material Browser’s eyedropper tool to sample the required settings and immediately paint the other face[s].
If some faces form a larger surface and you want a single seamless texture, then consider selecting one good face and Texture > Projected… then sample that with the eyedropper and paint the related faces in that surface…


#5

You only see Texture in the context menu when you right click a face that has a material applied to itself. If it shows a material inherited from a parent group or component the option isn’t available.

If a texture is stretched when first applied you can check in the Material browser if the texture has odd dimensions. This can also happen when painting a group/component that has been stretched with the scale tool. For components you can right click and select Scale Definition.


#6

This topic was automatically closed after 91 days. New replies are no longer allowed.