App never starts II


#1

Basically the same problem in the first App never starts post. There was no resolution there so I thought I’d start up a new thread. The app hangs on the loading icon and never starts. Looking at the console, I see an error message that says:

“Loading failed for the with source “https://cdn.ravenjs.com/3.22.4/raven.min.js”. app:105
[Show/hide message details.] ReferenceError: Raven is not defined[Learn More]”

I’ve tried clearing my cache and browsing history and restarting my computer but no change. I’ve tried on Firefox and Edge. Any ideas?


#2

Link for more context:


#3

You already opened the console to see if the incorrect operation is also accompanied by some error messages with more information. That is good!

ReferenceError: Raven is not defined means that a script accesses Raven, but another script that provides Raven has not been loaded.

This can be a temporary server problem, a network connectivity problem on to your browser or the address has been blocked, e.g. by an advertisement blocker or privacy browser add-on or another security software.
But if I open https://cdn.ravenjs.com/3.22.4/raven.min.js explicitely in a browser tab, it is loaded.

  • Adblockers or the browser usually show a message on the console when they blocked something (https/http resources mixed, cross-origin). Can you nevertheless try disabling browser addons that would filter/disable unwanted resources (add blocker, privacy add-ons)?
  • Can you check if your anti-virus software or firewall has logs where you can see what has been recently blocked?

#4

Thanks, I am using ad-blocking software that was blocking that URL. I’ve whitelisted it and the app runs smoothly now.


#5

I imagine you aren’t the only one using an ad blocker that is creating this problem. This should be a first troubleshoosting step for people reporting the same issue.


#6

This topic was automatically closed after 91 days. New replies are no longer allowed.