Anyone have trouble downloading 3D models from warehouse directly onto SketchUp?

Anyone have trouble downloading 3D models from warehouse directing onto drawing?

Could you elaborate a bit.

Your profile implies you are using 2017. The 3D Warehouse only supports the current and two previous versions. You can either download components from the 3D Warehouse via the Components panel or you can go to the Warehouse through your internent browser and download the Collada file. then import the .dae file included in it. Or you could update to the current version.

Please correct your profile. Operating System would be Mac or Windows. SketchUp Version would be 2017 (I presume).

Many people have had that issue. It can sometimes take many minutes for the model to appear in the scene. Try giving it more time, or download the model into a new document.

I was not aware of that! On occasion I will download directly into model just to find it nothing has changed, even after clicking a couple of times for insertion points. Should I just be waiting longer?

Tried all that but nothing happens when I click download. Worked fine all along until yesterday now nothing is downloading,

After clicking download, does the 3D Warehouse window close? If it does, and you click somewhere in the scene, try going to Edit/Component (1 in model), and choose Zoom Selection. Does the object you downloaded appear?

If you are using SketchUp 2017, 3D Warehouse does now show an error when you click on Download. As 2017 and 2018 are now not supported for using 3D Warehouse inside SketchUp, your only option is to use a web browser for downloading models. Or, do your search in the Components panel, and click on the thumbnail of the model you want to download. That will directly load the model into your scene.

Wait longer, or try the same download in a new document. Or download the model as its own file.

Same here. Seems the blue Download button is inactive to me.

What version of SketchUp? Please complete your profile.

No, blue download button dialogue stays on the screen.

What version of SketchUp are you using? Please complete your profile.

Screenshot - 10_11_2021 , 11_06_05 AM

“Business” does not identify the version.

I found that there is a script error happening, and I reported that to the 3D Warehouse team.