Always meet a problem about saving

image
I meet this pop-up window again today and lose my progress again. I already tried to save a few times but it keeps pop-up. Not sure why and I’m using SketchUp pro 2022.
Can anyone help me?

Are you trying to save directly to “the cloud”?

There have been models in the past that would show that message. Updates to 2022 took care of most cases, but your file might be a new example. Check to make sure that you are using the latest update to SketchUp 2022.

If you are, would you be able to put a 2020 version of the file online somewhere, for us to take a look at the file?

Oh, I just realize there’re a few different versions of skb file. I change it to 2020 version now and let’s see if this issue will appear again. I used the model version in past. Wait a moment… my file is too big so I just can upload it to google driver to send.

this is the 2020 version of my file which had that issue before.

If:

  • in Components panel > delete component 10kg disk

prg-04a

you’ll be able to save directly as 2022 skp version.

After that, using Purge command, your file will drop from 1700 MB (skp 2020) to 350 MB (skp 2022)

prg-05

Purge command is what I had learned just now, thanks! I check out the 10 kg and this component can’t be purged unfortunately…

If you read carefully what I wrote, you will see that the first step is to delete that component, then use the Purge command.

del-02

And I can save it as 2022 skp all the time but it’s error recently…After I purge the model, I can’t save it as model skp again.

What error message do you receive now?
Did you delete component 10kg disk ?

image
This is my problem, yeah. I can’t delete it, weird.

Try this then:

  • go to Outliner panel and delete both components 10kg disk
  • then go to Components panel and delete component 10kg disk.


Deleted. Useless…emmmm

Do not left click to select component in Components panel!
Directly right click over component and you’ll be able to delete it.

del-06

1 Like

Alright, it still doesn’t work. Either I delete components in the outliner at first or go to the component panel at first. Are you using SketchUp pro 2022 22.0.354?

Try this steps:
del-07

  • right click over the image > Open image in new tab to see it at full resolution

in
skp-06

…Thanks, just realize I’m using 22.0.316, a different version…

Although I don’t know what happened, the file size is reduced. 764MB> 354MB now. Thanks for the help! I’m wondering why I can’t delete components though.

You’re welcome!

Did you watch the animated gif? It should work in any desktop version of the SketchUp.

Read the Release Notes: SketchUp Desktop 2021.0 | SketchUp Help

Maybe it isn’t working on the Chinese windows system? Just the developer team knows.