All the new imported object and components are locked in vertical plane


#1

Please please help, I am new to SketchUp and while making a component out of pendant I aligned it to vertical which I should not have done (if so then to horizontal). Problem is now that all the newly-added objects snap to vertical plane and it is extremely annoying. Do you know how to fix it? I cannot understand that by aligning one component, I caused this…


#2

Is this about DCs (Dynamic Components) that are glued to a vertical face?
You can edit the properties of components in the ‘In Model’ component library.
You can right click a ‘Glued to’ component and select ‘Unglue’ in the context menu.

Otherwise, components always have their local axes aligned to the current drawing axes when you place them in space.
You can right click on a component and select ‘Change Axes’ in the context menu. This will help when bringing in new instances.


#3

Thank you for response. I can see that I can change the position of the newly-added objects by changing the axes of existing components, but it is all so floppy. Is there any option to reset all the axis to the initial state? It all had worked flawlessly before I made that “stupid” alignment… Thank YoU!


#4

I think I managed to reset the axes and the objects now add fine. Why did I change it? Thank you very much for explanation.


#5

This topic was automatically closed after 91 days. New replies are no longer allowed.