All .skp files gone (Win) and grayed out (Mac)


#1

I downloaded and use the latest version of the Sketchup Make 2017 software. I use it on my Mac at home, and on my Win 7 Ent. at work. I have some files saved on Google Drive, and some just locally on my machines. On my Mac this morning, I opened Sketchup 2017 > Went to: File > Open… and navigated to the file on my hard drive. The .skp file name was there, but it was grayed out and not click’able. I closed the Sketchup application, and just went to the file and tried to open it. It asked me to choose an application to open this type of file. When I navigated to Sketchup Make 2017, the application was grayed out and not clickable.

So, I went to my Windows machine and tried the same thing. On the windows machine, instead of being grayed out. the .skp files simply were not there when I went to file > open. And when I went to open them with Sketchup 2017 closed, it gave me the… “Windows cannot open this file. To open this file, Windows needs to know what program you want to use to open it.”

Has Sketchup changed their file extension or done something major in the newest release?


#2

It sounds to me as if your Google drive directory out in the cloud is unavailable.

Copy the files over to your local drive and try again. The general wisdom is that you should save files to a local directory and sync them to your Google Drive or other cloud-based directory. don’t try working directly from the cloud.


#3

No.

I’m with @DaveR. This sounds to me like the local Google Drive interface is trying to cope with problems connecting to the cloud storage of your files and is thereby confusing both Mac and Windows.