This does not appear to be a SketchUp model!


#1

Hi, am a Sketchup newbie. Am trying to transfer files between Mac laptop where the file was created, to both desktop Mac, and PCs. by saving the drawing onto a USB. All machines are running Sketchup Make 2017. Transferred the .skp file into the default directory on each machine, but each time I try to open it, it give the above message. It then says xx file could not be opened. Why does Sketchup not recognise the .skp file? Very frustrating. Have tried several different drawing files, on different USBs, so don’t expect it to be a corrupt file issue? Have also tried to import the file, from the USB, with the same error message.

Any ideas?


#2

I regularly move SKP files between Mac and PC on memory sticks without problem. Have you tried uploading the files to the 3D Warehouse and then downloading them to the other computer? Or maybe use Drop Box?


#3

Or maybe upload here to see if anyone else can open?


#4

To check whether the reason why computer B can’t open a file transferred from A is due to file corruption, transfer it back to computer A and open it there.

Do you open the file directly from the removable drive, or did you try to copy it first to the local drive (desktop)?


#5

I tried both. Copied file into default on PC, and also attempted opening direct from the USB. Same result. Will give the file on the USB back to my son in law (who created it on his mac laptop) and see if he can open it.


#6

Scroll down untill you’ll see the real . Skp
Windows seems to make some kind of ‘backup’ when importing from a usb that has been formatted on a mac


#8

I just noticed you haven’t described yet how you open the file. There are usually two ways, 1. double-clicking and letting the operating system look up the default application, or 2. through the File → Open… file selector dialog in SketchUp (forcing SketchUp to open that file.

Also, turn on file extensions (e.g. on Windows in Explorer → Folder Options → View) so that you can distinguish .skb (SketchUp backup) from .skp files.

The message “This does not appear to be a SketchUp model!” comes from SketchUp starting to read the file, so I assume we can exclude the possibility of invalid characters in file name or file permissions.


#9

My simple way of noting validity, on a Mac, when people try to sneak ■■■■ into 3D Warehouse: open Utilities/Terminal.app, type

hexdump -C

(with a space at the end), then drag the model from Finder into Terminal, so it becomes something like:

hexdump -C /Users/bjanzen/Downloads/Untitled\ 5.skp

Then tack ‘| head’ (that’s pipe head, or the key about \ on your keyboard), so it’s

hexdump -C /Users/bjanzen/Downloads/Untitled\ 5.skp | head

00000000 ff fe ff 0e 53 00 6b 00 65 00 74 00 63 00 68 00 |…S.k.e.t.c.h.|
00000010 55 00 70 00 20 00 4d 00 6f 00 64 00 65 00 6c 00 |U.p. .M.o.d.e.l.|
00000020 ff fe ff 0c 7b 00 31 00 38 00 2e 00 30 00 2e 00 |…{.1.8…0…|
00000030 31 00 36 00 39 00 37 00 36 00 7d 00 ad 9a 9a a2 |1.6.9.7.6.}…|

So this is a SketchUp Model made in version 18.0.16976. If it doesn’t look like that, it’s not a SketchUp model.