Advice on importing and using DWG file

I’m using a DWG file from a professional survey and having some issues with the geometry. I’ve treied following the video on the SKU education you tube, which is really helpful, but I’m having issues with faces. I want to create tidy grou
DWG import issue.skp (616.5 KB)

ps with the geometry I want to use (buildings, walls etc) so I can build it into a 3D model and add in my design. Eric’s advice in the video is to explode the CAD file and then use tags to create groups, which is waht I’ve tried doing. However, even when I turn off the tags for the geometry I’m not working on, it seems to be messing with the visible geometry somehow. For example, when I try and create a face in the rectangle on the left by closing the goemetry, I don’t get a nice face where I’d expect it, but some messy faces nearby. I’m new to using DWG files, so its probably my lack of experience, but some advice on how to proceed would be very welcome.

Check the scale

Try to import again in a new file, in Options set the scale correctly.
You have that 2D person in the model to get an idea of the scale.

The import unit can be set in the Options dialog that opens from the Options button on the Import File dialog.

Those faces/edges look really distoted.

Select everything and move them to the middle of the SketchUp origin (the axis)


There is also an options box when you import it to “preserve origin”
Turn it off if it was on or vice versa and try again

Thanks for the advice folks.

I’ve configured the import to metres (standard in the UK) and preserviing the origin. Howver, I have a new issue. Although my geometry has tags, I can’t seem to see them in the tag tray, although when I look at the entity info it’s all there. Any ideas? I’m sure I can work around it, but its a bit odd.

Are you using SketchUp 24? There is a bug that prevents the tags from initially showing in the tag window. Add a new tag to get the window to refresh. This should only happen the first time, then work fine after.

Never mind, I see in your screenshot that you are not. Upload your file.

or better yet upload the original .dwg

Beware of ticking the “preserve origin” box when importing map files. Their origin can reside thousands of kilometers away from the actual data, and SketchUp doesn’t like large coordinates. You can get strange display artifacts and worse. Better keep your model as near the SketchUp model origin as possible.

RBS-24-3696-001.dwg (691.3 KB)

Thanks. It’s definitely more complex than I thought. Here’s the DWG, file. I do seem tyo get a bunch of things which haven’t imported, but i don’t think I lose anything I need, as i’m really looking at the terrain, buildings and location of trees/foliage.

Try this version. Does this get you what you need?

Fresh Import.skp (7.1 MB)

Thanks for this. It’s definitely a step in the right direction. I need to make more faces of the other buildings etc. What steps did you take?

I can see you’ve managed to import more of the file than I had. Is that because you’ve used SKU 2024? I’ve put off upgrading until I have a few days without billable work, but if it fixes some problems it might be worth bringing it forward.

In SketchUp 2022 - 3D terrain and 2D plan with tags

1 Like