Adding a new scene tab dislodges tray containing scenes

Hey folks, my title says it all. I have no explanation as to why this is happening. SU was running fine and then all of sudden this mess takes fold. I tried reinstalling but the problem remained. I tried system restore and i got it to work again but as soon as i started moving trays around the problem came back. I then loaded up one of my files onto another laptop of mine and the problem was even there as well even though it wasn’t there before. Very strange. It is as though my corrupt file somehow did this or something.

As you can see in the video, only when adding scene tabs with the scene tab rollout expanded does the problem happen. And its happening even with any new document.

I am bewildered as to what is going on.

I am also very annoyed.

If anyone has any experience with this or any suggestions i’m all ears.


I like having my trays like that because having all the dialogs (scenes, layers…) in one tray means a lot of scrolling whereas with multiple trays i can access whichever dialog i want instantaneously without needing to scroll. In fact, i cant imagine working any other way.

When i use only one tray the problem doesn’t happen. The reason this is so is because the problem only happens when the scenes rollout is expanded and when i switch to the scenes tray. With only one tray there is no switching so it doesn’t happen.

Also, if i use this setup where i have another panel containing the scenes dialog and having no other trays then the problem is also not present since once again there is no switching.

I just cant figure out why this is happening. I have been using SU like this quite some time now and it only appears now.

How else are trays designed to be used?

@DaveR i kind of like having multiple trays. But i will examine your ordering of dialogs.

As for the problem, i wish i knew how to fix it.

Dave, sorry but you are wrong here. Microsoft designed the tray system many many years ago. (I believe even before the first version of SketchUp.) They work the same in all MFC applications. They were designed to be totally flexible. Ie, this means that the user has total control. The user can have as many tabbed docked trays as they wish. They can have others autohide (slide out) into whichever margin they wish. They can have whatever panels they don’t need hidden. They can have whatever panels they want in whichever trays they want. They can have some closed, some open, some docked, some floating, some auto-hidden, etc.

The SketchUp team only migrated the tool window inspectors over to tray panels. They didn’t “design” much (if anything) else about them.

Although it looked to me as if he had 2 panels per tray, many users that want a certain panel “on demand” via a keyboard accelerator, have these single inspector panels on a tray of their own, because it is the trays that can have shortcuts assigned to them.

When they use these shortcuts, the floating tray with it’s proper panel is displayed floating, used and then dismissed.

Some users with multiple monitors prefer these “on demand” trays to appear on the secondary display.

Incorrect. Review the video.

He has both the “Layers” and “Scenes” panels, within a custom tray named “Layer”.
Further more all his trays are docked and tabbed. He does not have them floating, he is complaining of a bug the keeps causing his “Layer” tray to undock and become attached to the mouse cursor when he adds a new scene to the model.

I myself, also use this dual panel per tray scenario, and have had no problems.

Back to the issue. I just tested a bit on SketchUp 2016, and I find that the issue happens intermittently, when one of the trays “thinks” that the tray tab was double-clicked. Simply, double-clicking again will redock the tray that is attached to the cursor, back where it was before.

I think it may be just that the timing of clicks needs to be lengthened, which is normally a function of the mouse control software, not the application. Ie, my Logitech mouse uses Logitech SetPoint. Microsoft Mice use MS IntelliPoint, etc.

Another possibility is that the mouse switches may be wearing out.

1 Like

@DanRathbun, thank’s for the suggestions. However i don’t believe it has anything to do with the mouse. I tried playing around with the settings and nothing happened. Furthermore, the problem has been absent since SU2017 has been out and is only appearing now and on two different laptops - one an MSI and the other an ASUS.

For me it is as though one of my files got infected and then when i opened it up to test it out on my other laptop i wound up infecting that one too. Although this seems odd that a file could be infected this way, i just have no other way of explaining how two completely different laptops with different makers (and different mice) can suddenly produce same problem.

Also, re double clicking back the tray containing the scenes or closing the scene dialog adding a new scene tab from the scene tabs themselves and then re opening the scene dialog is doable but very frustrating to someone like myself as like everything organized and in proper function.

Right now i am just using two panels like in the photograph i uploaded above. The only drawback to this is that i lose screen space. I prefer to have only one panel with many tabs like my setup in the video outlining the problem.

I think what i will do is just keep using two panels to keep working and every day spend an hour or two trying to find a fix.

Again, if anyone has any suggestions i would seriously appreciate them.


Problem fixed.

First, by holding down the mouse button for a longer period of time when selecting the tray containing the scenes tab after creating a new scene the problem doesn’t occur.

Here is a video showing this:

But if you closely examine the video you will see that there is popup window that appears at the center of the screen, which i discovered to be the heart of the problem. That popup window says ‘Generating Scene Thumbnails’.

Here are two pictures of them snapped from the video:

The solution to the problem is to uncheck the ‘Use Scene Thumbnails’ in the top right corner menu of the scenes dialog.

Here is a video showing that:

Thank god i found the fix. Living with such a bug would be very bothersome.

1 Like

Well this IS a mouse issue. At least in how SketchUp is dealing with the mouse clicks on the tray tabs.

Oh, I never use thumbnail views. Always the name listing, to avoid slowing SketchUp down.

1 Like

I too am only using the name listings now.

The fix i described actually doesn’t fully work. If you delete a scene and the scene before it in the scenes dialog is one that has an active thumbnail then SU ends up reactivating the ‘use scene thumbnails’ option and the problems returns.

The only true fix is to remove all active thumbnails, and in doing so there is no point in having the large thumbnail, small thumbnail, or details view.

I also find name listing allows me to fit many more scenes on screen.

If only we can change the name of a scene by right clicking on a scene tab then i would keep the scenes dialog in the trays minimized to conserve more space for something else. But that is a question for another day.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.