Add Location not working

Hmmm. I was sure I’d grabbed it before, but when I tried this morning I got this:

1 Like

so perhaps it is an intermitting problem, I remember you saying you managed in the past. Maybe the issue with windshearing at the new airport is causing the problems … :slight_smile: (background: recently completed airport, although certified, has wind shear issues preventing larger planes like 737’s being able to land)

Is this a Mac issue only?

I’ve been able to get your location on my Windows machine several times without fail. I haven’t tried it on my Mac, though.

I hadn’t tried the grab either…


I looked at the system logs via Console, and I see a great flood of GoogleSoftwareUpdateAgent and GoogleSoftwareUpdateDaemon messages when I try the grab. Perhaps Google has changed the interface and SketchUp hasn’t followed along?

Seems then it may be Mac related. Where in Apple would one report this to. Surely SketchUp programmers would have a conduit directly to Apple to sort this out?

I don’t think it is Apple’s problem, it has to do with the interaction between SketchUp and Google Earth. Hopefully one of the Trimble team will see this topic and they can investigate.

On Windows.

something is amiss with this on mac’s…

Ones that I can grab are ‘sometimes’ coming in with blank images…

@Barry my user agent is reported as…

"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_5) AppleWebKit/601.6.17 (KHTML, like Gecko) SketchUp/16.1 (Mac; Safari)" = $3


Ok thanks Dave and Mr Baumgärtner! But if it works for Windows and not for a Mac, surely Apple could be involved in sorting this. I wrote on a Google Maps forum, Noisette responded, not being able to help directly. Maybe I should direct Yogesh to this topic …

I can confirm a failure on iMac 5K, El Capitan 10.11.5. I can browse in Google Maps using Safari or Chrome to St Helena Island (though it took two attempts in Safari before it found the location) and view, zoom and pan across the terrain and satellite views, seeing what I would expect.

But like Steve Baumgartner above, I get the same error message in Sketchup when I try to Grab the location - I tried a small region around the Museum of St Helena in Jamestown:

"Add Location failed due to an internal error (import snapshot).

If this problem occurs again, please consult the SketchUp Knowledge Center for assistance."

There are other places on the earth that Maps API may not work - you just haven’t found them, and you’ll have to file with Google. The only thing I’m curious about is the fact that we get different results on Mac & PC, and I did file an investigative ticket for that.

1 Like

Have P C here but, it was not uncommon in years past that one would download large files during the night to make use of the higher speeds. There were down load mangers which allowed breaking files into to smaller chunks so if error occurred you did not have to restart download from scratch. I have to re-read your post in detail but seems like you have not had any discussion with your service provider. If this worked before and has stopped there is a good chance you have made some changes, net service provider has made some changes or there has been some changes in the net link some place or even failure. The service provider should be able to run checks for you. Modern modems have the capability to run test that ckeck TXand RX power levels just by the Http link you sign in with. Checking you modem user guide may have that info.
When you input add location does it default immediately or only after you select area.?
Can you post the location you are trying to add?
Some suppliers will send updates via expedited mail. Have you checked that with Apple?. Check for a download manager app.

No need to answer may questions above. After reading all post most are there.
Wind shear IMHO should not be issues with the Intelsat 707 Ku band link antenna. Ku band is good for rain attenuation, links will have some margin to operate with spec rain rates, polarization is circular which is good and they are usually even designed for snow loads although NA for your case.
There are many players to close a link and it may not be Google nor Trimble causing the problem. The up link is a bent pipe so no processing on the SAT.
They should take an active role in helping you which appears they are sort of. Hopefully they have logs or some others in the processing pipe line do and can and sort out where problems occur.
The imagery dates you have issues is shown as 2014 but then shows Imagery @2016 CNES Astrium, Digital Globe. I have yet to search under stand what that means.
Goole Earth has some options that I would change to see if they affect results but don’t have mac so it maybe different but you may want to check.
Good Luck

Hi Dave, I wonder if you can help me ‘clip grab’ a location on St Helena Island. This is still not working. I will send you a screen shot of the particular area if you can ‘grab’ the location and email me the file, I will be able to complete my presentation for a very sensitive heritage application. Thanks (

Send it by private message and I’ll make the grab as soon as I get home from work.

Hi Dave, attached are two screen shots of the area. One shows the overall
area on the island, and a more detailed area showing the actual extent of
the ‘grab’ required (basically a square area from Plantation House (the
governor’s private residence) at the bottom left side and Heart Shaped
waterfall on the top right hand corner.

Thank you for the help.

Yours sincerely


File sent via PM.