Accessing preferences after opening sketchup


#1

OK… these are the instructions for installing a plug in:

Download the .rbz file and save it to your download folder.
To download it's best to right click on the download link and use the option "Save Link As... "if that is available.
After downloading, Open SketchUp and go to SketchUp Preferences. Pick Extensions. Then Install Extensions. SketchUp default file format for extensions is .rbz.
Select .rbz from your download folder.
Install the Extension automatically. Once this is complete, plug-in will be available either as a menu item or a context menu item.

I open SketchUp and have right mouse clicked on everything and preferences is not an option. Where is it?


#2

Where did you get the idea that you right click on anything to get to Preferences? There’s nothing in the copied text that tells you to access Preferences with a right click.

Preferences is found in the Window menu.

The instructions you copied and pasted are old. For SketchUp 2017, go to Window>Extension Manager and use Install Extension there to install extensions you’ve downloaded to your computer. You really should just use the Extension Warehouse or the Sketchucation Extension Store to automatically install extensions.


#3

Thank you. True, nothing said to right click but it does say open SketchUp first. - but no menus with supporting options pop up unless you right click on the icons present after opening SketchUp, and these are the “current” instructions after browser search term “involute gear plug in for SketchUp 2017” is entered and use first site provided. I have no way of knowing if the instructions are current or not. I tried to refine the search for the involute gears plug in via the extensions warehouse but that was confusing because everything kept pointing to the engineering toolbox but nowhere could I find a listing of what the engineering toolbox included in its tool library, though I suspect it does include involute gears. But further reading of other users responses indicates it does not. I’m trying to install only what I need to accomplish my immediate task and trying to avoid irrelevant clutter which would only worsen the learning curve. And as stated in my other thread… I have never installed a plug in in anything. I don’t even know how to get to the extension manager… nothing matches in window search field results.


#4

So do not make assumptions. Web searches find things using only partial matches.

Those instructions have not been the preferred method of installing plugins, since SketchUp 2013 was released.

Don’t search the web. Go to the SketchUp Extension Warehouse or the SketchUcation PluginStore, and search the stores.

Re, location of Preferences. SketchUp has an online User Guide.
http://help.sketchup.com/en/content/sketchup-make-and-sketchup-pro

In which you can read all about the preferences: Customizing SketchUp

Extension Warehouse has it’s own User Guide:
http://help.sketchup.com/en/article/3000260


#5

there now and learning how to use it. (I hope)


#6

I thought perhaps Jim Hamilton wrote a gear plugin, but he has his own company website (spirix?)

@jimhami42 ?


#7

Here is a post he talks about it (and gives the link):

But it is a plain rb file, not wrapped in a zip. (rbz is just a renamed zip)


#8

This is what I’m doing according to my understanding of the instruction provided for the auto plug in installer in SketchUp. What am I doing wrong? because I don’t get it. It all seems straight forward instruction wise - but it is not working via Extension Manager OR via Extension Warehouse.
As stated in both of my threads… I have never installed a plug in in anything.


#9

I did go to the SketchUcation Plugin Store and that is where I got the Cadalog_Gear v3.1.rbz download for involute gears and when following the Extensions Manager route it will not install. WHY? What am I missing? What am I failing to do? Is there an in between step I don’t know about? The process just keeps jumping back to my download directory and lists it’s only content… that of the plug in for SketchUp for involute gears… Typing Involute gears in the extensions warehouse search engine takes me to the engineering toolbox and persons have commented and I quote Dave B’s review " Was hoping that I could make a gear with this. Any programs out there that will do it (in Sketchup)?" and Ryan P’s response “same i cant find one either”… So the Extension Warehouse’s Search Engine will not take me to a plug in I need but it also will not take me to the Plug in when I type in the actual plug in name CORRECTLY!!! Why does something that is supposed to be so automatic have to be so freaking difficult?
I’m going to write this next line one more time and I’m getting kind of tired of emphasizing it (mainly because I also have to do all my typing one-handed due to left side paralysis from my stroke).
I have never installed a plug in in anything. I have never downloaded an app for a smart phone (never owned one), but I can write config.sys and autoexec.bat files all day long.
Making the jump from Windows 95B to Windows 10 was not without a learning curve either.


#10

Once you select the file click the Open button, not the Install Extension button.


#11

I’m not too familiar with the new extensions manager, does he have to enable the extension toolbar manually after install?


#12

Whether or not an Extension’s Toolbar is active when that Extension is first loaded, depends on how the author codes things.
Usually it won’t be, and then you’ll need to activate that Toolbar [just the once].

Note that whether or not an Extension is itself enabled when it is first loaded is also somewhat up to the author’s coding choices.
Usually if will be initially enabled, but even if that is the author’s intention the new Extension Loading Policy can sometimes mess with that…
Again a one time enabling should leave it as you desire.


#13

Thanks,
I noticed some do some don’t in the few I use.
The case is the same then for 2017

I thought Iwould drop that question in there to make him aware that as/when he installs the extension it may not appear.


#14

My involute gear plugin has been reworked into one that can also provide a rack (linear) gear. It was originally the brainchild of Doug Herrmann, although it has been modified a bit since then. It has been tested with 2017 and can be found here: https://sites.google.com/site/spirixcode/code/jimhami42_rack_and_pinion.rbz

This is an RBZ file and may be installed as any other extension (although you may need to override any signing restrictions).

BTW, “Spirix” is the name of my original spiral-helix plugin … the website is Google’s free site. So is all of my code on the site :slight_smile:


#15

Note the video link please… I’m not great with searches on computers but hey… I FOUND IT!!! I downloaded it and it adds itself to nothing from what I’m seeing. How do I install this plug in? Is it self extracting and self installing?

I’m guessing Extension Manager can’t install it because it doesn’t have .rbz as the file extension, and there wasn’t a single instruction where I found it… just a pretty picture of some beautiful ivory colored gears on a jet black background.


#16

@Confused - Try this site: https://sites.google.com/site/spirixcode/code/jimhami42_rack_and_pinion.rbz


#17

The open tab was the first thing I did like always with any download esp considering it was stated it installs itself in the draw options list… clicking “open” does nothing.


#18

Same exact problem… Straight to the download site… do the download… run… nothing… re-download… save… extension manager identifies it but will not install it… after extension manager identifies it… open will not install it either.
I didn’t know SketchUp was capable of duplicating a bureaucracy!:rage:


#19

Look at the image I posted. The Open button on the dialog where you have selected the rbz. Not the open file option.


#20

Guess what I just found? I was always looking for a new tool icon with all of these extensions…Silly me… MY BAD!!! It is exactly where you said it would add itself to… the WORD Draw drop down menu. Problem Solved…
now gear drawing play time… learning curve resumed.
THANK YOU EVERYBODY


Gearing Up with Sketchup