'Accept Terms' checkbox missing / Extension Page Editor broken?


#1

Hi,
for several days now i’ve tried (and failed) to make changes to the extension page my already published extension. After i’ve made changes to the description of my extension and want to save and publish them i get the error message that i haven’t agreed to terms and conditions. Unfortunately the checkbox i’m supposed to use to accept terms and conditions is missing. I remember that the checkbox has been there in the past because i (successfully) made several changes to my extension’s description. Already tried various browsers, disabled ad-blocker, cleared cache etc.

Does anybody get the same error and/or can point me to a solution for this problem?

Thx
Ender


#2

Ender,
Can you logout and login again to see if it reappears? It should be just below the Current RBZ file listing.

Best Regards,
Nick


#3

Thx for the suggestion … unfortunately that doesn’t work either. This is what the page looks like:

As i am hosting my extension outside the warehouse i am using the ‘listing page’ option. Still the checkbox for accepting the terms used to be there in the past.


#4

That is interesting, I’m not sure what is going on there. I’ll pass it on to our engineering team to take a look at.

Chris


#5

Appreciate someone looking into it … thx.

Interestingly enough the checkbox is showing up if i create a new extension. As soon as i check the ‘listing page’ box it vanishes again, but remains part of the page and is just set to invisible while keeping it’s checked state. So if i check it before checking ‘listing page’ i am able to save or preview my draft. Still probably not the intended behavior.

Ender


#6

Dear SketchUp Team,
We are having the same issue with the missing checkbox for accepting the terms together with the ‘listing page’ option at our published extensions.
Do you have any news here? We would very much like to get our Version for SketchUp 2017 out there…
Hans, 3skeng


#7

Realizing it is (by far) not a perfect solution i can suggest a workaround for this problem:

If one tries to create a new extension description page rather than editing an existing one the ‘Accept Terms’ checkbox is there. Using Chrome’s Developer Tools (or whatever tools one’s favorite webbrowser provides) one can now simply copy all HTML form elements belonging to the checkbox and paste them into the editing page of the already existing extension, check the box and submit the modified page. The Extension Warehouse backend will then accept the modifications to the page. I’ve already used this workaround several times now.


#8

Dear SketchUp Team,
thanks for fixing the issue!
One just has to click once on “Save draft” and right after that the “Term of Use” checkbox appears and the changes can actually be saved!
Hans, 3skeng