Acad 2000 files import with reversed geometry

import

#1

Hi all.

Just switched from pro 2017 to pro 2018, and all looks fine. Until I import dwg files.

The files are simple Acad solids made in Acad 2000 (yes, I’m that old). I already imported these same files into pro 2017 with no issues at all. Now those same files seem to come into pro 2018 inside out. For example,
a simple solid cube looks okay, until I paint a color unto it. The color only applies to the inner faces, as if the normals are somehow reversed. If I try a more complex solid shape, say a rectilinear shape that turns corners, it comes in with the geometry inside out and upside down.

Changes to settings are not making any difference. Any ideas?


#2

You might want to have a look at this thread:


#3

Thanks DaveR, but that looks unrelated to my problem. I’m going from CAD to SU, not the other way, and no curves or DXF files are involved. Besides, the beauty of building with solids is that the normals always face outward, at least for the simple shapes I’m transferring.

Actually, in my 25 years of transferring my Acad files to other programs, I’ve never encountered this before. Strangest thing I’ve ever seen, and these are the exact same files I imported to SU 2017 without problems. Gotta be something about my pro 2018 installation?


#4

can you share a dwg that we can have a look at?


#5

Sure Chris, here’s a simple dwg file I made this morning.

Turns out the second part of my problem was my own fault, so forget the inside out/upside down geometry stuff. The only real problem I’m having is that the Acad2000 solids I import into SU pro2018 have their faces oriented inward instead of outward, which makes 0 sense for a solid object.

I tried importing this files into SU pro2017, where materials painted properly (on the outside of the cubes). Then did a copy/paste of the file into SU pro 2018, and the faces remained oriented to the outside. Then did the import dwg of the same file, and the faces were once again oriented to the inside of the solid cubes. As I said, that makes 0 sense to me.

Of course, a work around is to have SU reverse the faces of every solid I import, but there are hundreds of those in every project I do, so not at all practical. Sure hope someone knows of a setting somewhere that can simply be changed to fix this. So far, I can’t find it.

Thanks!PeopleHeights.dwg (66.5 KB)


#6

@digreal

I am not seeing the reversed faces issue. In the graphic below you can see your dwg imported into SketchUp 2017, 2018 and 2019. The face view setting has been set to Monochrome in order to see the face normal orientations. All the imports show the normals facing outward and the non-normals (blue) facing inward.

If you are not seeing the same, perhaps upload a screenshot so we can see what you are seeing.

CD


#7

When I import the file, it is already painted with a blueish material, both inside and outside.
image


#8

Aha! Excellent observation, Chris. You’re right, the faces still import with the correct orientation. It’s some new material called . In past versions of Sketchup, it always assigned the material default to my dwg imports. Now it assigns this material instead. Simple work-around is to delete that material and let SU replace it with the default. Then my imports can be painted as always.

Much better than reorienting the faces, but still a nuisance. Any idea how to get pro2018 to use default on my imports, like it always did before?

Thanks!


#9

For me, it’s white. Which I guess is why I didn’t notice it at first. I can change it to a color in the editor, which makes it seem like any other material. Except I can’t paint over it… as though it’s locked. Nothing is different at the Acad end of this, where I don’t even use materials, so can’t figure where this strange material is coming from.


#10

The unwanted material seems to get made during the import.
To remove it, just delete the material from the model’s material browser.
Then any faces and groups/instances using it will revert to the front/back-face default colors.
Ensure your Style is set up to have a distinctive back default color.


#11

Yeah, I already figured that out. Like I said, really just a nuisance now. In fact, I already figured out how to make it work in my favor for some imports. Sure is a relief knowing it’s not the geometry changing.

Thanks for all the help, folks. Much appreciated.