A face that won't face

I’ve got a face that as far as I can tell, should be an independent face (edge tools says it’s all good and if I ctrl-move it, it’ll face), but it doesn’t want to be an independent face, circled in the far left of the skp. Anyone got an idea or solution?

facequestion.skp (166.3 KB)

I see a rectangle (group) that is glued to the larger face beneath. You can right click on the group and: either explode it to merge with the larger face or ‘Unglue’ the group.

The other rectangle (square / group) is not glued to the larger face. You can also explode it to merge with the larger face.

Hey, thanks for looking, the spot that’s an issue is the triangular meeting between the f-spline, the rectangle w/ line pattern, and a little arc section

Please make a screenshot in which the spot is marked.

Very small Z difference. Ran eneroth flatten to plane.
facequestion (1).skp (175.4 KB)

1 Like

Thanks! No idea how the z-dif got there.
Does flatten to plane work in 2020? Totally failed at holding onto my 2019 install w/ extensions.

1 Like

Yes, works great. I did this in 2020 and backsaved to 2019 because that’s the version you have listed in your profile. Maybe update that when you have a chance.


Just did.

What value as difference?
I could split/repair the faces by moving two vertices in plane.

image to C

  • draw a short edge A-B to isolate the last curve segment (and small “error” face)
  • move A to C
  • move B to C
1 Like

oooh, slick! How’d you determine that was the failure point?

Drawing edges across narrowed down the selected “split”-face to the direction of point C
To keep the same shape of the curve you need to move its adjacent vertex on the curve, the one closest to C (=B). A-B is just an edge to be able to select that point B. Otherwise you would move the whole curve.

@endlessfix, whatever vertex I measure, I see Z-differences of 0.000000mm.


I’m sure you are correct. To be honest I never measured, I saw the problem and ran flatten to plane and it was repaired so I had assumed a z difference issue (foolish of me). Good catch.

I messed about with some lines too and determined that corner as the problem area but moved on when flatten fixed it. I guess this was really a tiny edge issue, but i’m still unclear how that happened, or why flattening to 0-Z fixed it.

I’m not sure either. I think it has to do with the order of how loops are created (even in plane).


  • on a large face …
  • draw a rectangle
  • move one corner over one of its opposite edges and you’ll see faces either disappear or acting strange.

yeah, I’ve seen that disappearing act before. I played some more and I’m convinced you are right, this is some version of that order of operation / contained loop problem: exploding the curve of one edge and redrawing fixes as well, but then destroys the independence of the shape next door.

Maybe some part of Eneroths flatten script inadvertently clears lingering data in the geometry.


You have Enable Length Snapping turned on in Model Info/Units. Disable it as it tends to create tiny errors.

1 Like