3Dconnexion SpaceMouse not working in SU 2023

Found it! And it worked to boot :tada:


Worked as described. Thank you.

1 Like

I could not find it either until I shown hidden folders and files. Then I was able to copy from 2022 to 2023.

I’m trying to follow along to get 3D mouse to work in SUP23. On a Mac also. Oddly, I do not have a “Sketchup 2023” folder in app support. I have folders for SU versions from 2013 - 2022, but not 2023. I’ve quit and restarted both Sketchup and my computer 3x’s and still no folder.

Hmmm… any thoughts?

As I noted earlier, the folder for 2023 might not exist yet, in which case you will need to create it before doing the copy. So far as I know, SketchUp itself doesn’t create it automatically.

Few extensions use the main Library Application Support folder, so there is a good chance the only extra thing you added was Space Mouse support. You could use the Go to Folder… menu item on the Go menu, in Finder, and paste in this path:

/Library/Application Support

then duplicate the SketchUp 2022 folder, and rename it to be SketchUp 2023. You may be asked to enter your Mac password a couple of times.

1 Like

I just saw that in your post. Tried it, restarted SU and computer, nope, no Spacemouse working

Yes! Success this time around! Thanks Colin.

It may well be different on Mac, you may need to invoke the name of steve three times, but on windows the structure is simple but overly complex.
The 3d Connexion driver installs a folder and .rb file in a Sketchup plugins folder that may or may not have already been created. It will create it if it has to. It does this in Program Data rather than in the normal plugin folder in …Roaming…
Several other things will also use or create this folder, Twilight Render for one. I’m sure there is a good reason for it in the minds of those that designed it this way.

But, to put it simply, you can find the .rb and folder, cut it and paste into the normal plugin folder and it will work. This is a simple way to add it from 2022 to 2023.
This works because the ‘Driver’ for the Connexion is just a plugin. The driver install will add what it needs to work in various programs and for Sketchup it is just a single file and folder.

As I have said many times, I know nothing about Mac, but it would be interesting to see if the situation is similar in that file structure. If so it would simplify the process. If not… Oh well

If you don’t keep sketchup 2022, you just need to rename the library folder from Sketchup 2022 to Sketch 2023. Worked for me.

Those who have gotten this to work are you on older intel MBP or M1/M2. I am on M1 and still have not gotten this to work.

  1. New driver from 3DConnection
  2. Copied MacIntosh HD/Library/Application Support/SketchUp 2022/SketchUp/Plugins to MacIntosh HD/Library/Application Support/SketchUp 2023/SketchUp/Plugins
  3. Multiple reboots.

I am on MacBook Pro 16 with M1 processor.

Notice that copying the files didn’t work for clearplanmodeling, but duplicating the folder did. I wonder if there are permissions issues if you manually make the folders and copy the files? You could try the duplicate way.

I am on a Mac Studio with a M1 Max Chip.
As mentioned before, I did not copy into a new folder, I just renamed the whole library from …/Sketchup2022/… to …/Sketchup2023/…

I am on a MAC BOOK M1 too,
As mentioned, go to the root dir, in FINDER select “Macintosh” HD
/Library/Application\ Support/SketchUp\ 2022.
duplicate and rename …\2022 → …\2023
restart SUP 2023 , worked fine on my system

Thank you all for the fix.

Thanks to everyone for the suggestion and workaround to get the 3d Space mouse working in SU 2023.
following the instructions above it worked fine for me.
I have an IMAC running macOS Monterey Intel chip.
Hopefully, 3Dconnexion support team will release an updated driver very soon, so that everyone can use their product with this version of SU
Have a good day

Hi All,

Space mouse Wireless not working since upgrading SketchUp to 2023 version. I did download the latest 3DxWare (v10.8.12) but to no avail. Was working great in 2022 version of SketchUp.

I do have 2022 still installed, but am quite confused with instructions noted above. I am running MS-Windows 11, SketchUp 2023 and 3DxWare 10.8.12.

Suggestions please?

Did you try what was suggested in this thread?

Please update your profile with SketchUp version, operating system, and graphics card.


OK, I’ve updated my profile per your admonition. Although I don’t think it will help me much.

As for my issue with SU2023 and Space Mouse, no I haven’t “try what was suggested in this thread?” as for what I see the dialog pertains to Mac based issues, not MS-Windows 11. Perhaps you’d care to be more specific? or have a suggestion that pertains to my issues other than ‘update yer profile’?

Hey All,

Have new M2 Mac Mini with SketchUp Pro 2023 up and running with
3DConnexion Cad Mouse Wireless working fine. Unfortunately new Space Mouse Enterprise does not work with anything except 3D Connexion training program.Installed and reinstalled Sketchup several times with restarting of computer. The SketchUp Plug-in folder is correctly labeled and in the right place. Is it possibly an issue with the new Mac M2 chip? Any ideas?

The 3DConnexion driver does not yet officially support SketchUp 2023, though that seems to be an installer limitation as multiple people have gotten it to work by manually copying the extension from SketchUp 2022. They have said in their forum that an update is coming, but as usual on Mac they have missed the target they mentioned.

That said, I have no explanation for why your wireless space mouse works but your enterprise does not. Edit: oh, wait you wrote cad mouse not space mouse. The cad mouse emulates an ordinary mouse from sketchup’s perspective so it doesn’t require the extension.