3Dconnexion space pilot does not work in SUpro

It used to work fine and SU supposedly still supports it. What could be wrong?

Maybe you need to get the updated driver for it from 3D Connexion.

It will only work if the app is installed After the version of SU…

and then it needs to be turned on in Preferences…


If SU was updated from SU15 to SU16, well SU16 is a separate installation. The installed 3dconnexion device doesn’t pick up that something new was installed. So install (or re-install) the latest driver.

3dconnexion is a 3rd-party hardware/app that includes support for SU - SU doesn’t offer support for 3dconnexion’s products.

They stopped supporting drivers after 2013, does any one know
which works with a space pilot?

Off to work I go! THX

What preferences I can see nothing in SU.

the SketchUp menu item Window >> Preferences >> Extensions…

or SketchUp >> Preferences >> Extensions on a mac…

it should be shown as an extension which you can toggle off/on… [off only after restart]


3dconnexion changed where it installs stuff for SU. It doesn’t install anything in the Plugins directory. Nothing shows up in Window > Preferences > Extensions.

3dconnexion did drop support for its original Space Pilot several years ago after releasing its Space Pilot Pro. But people still could install the latest driver software. It ‘just’ wasn’t officially supported. So you are on your own on whether or not your system will run the latest 3dconnexion driver. (FYI, I did use the latest drivers with my unsupported Space Pilot up until the hardware malfunctioned and was replaced.)

Most every new SU version needed some 3dconnexion driver update for their hardware to work. Update the driver. If that no longer works for your old hardware, you need to replace it. I got my Space Pilot Pro from Amazon marketplace. It was used but affordable - and supported. It’s firmware can be updated if needed. You should contact 3connexion support. They always been very helpful.

It still does on the mac version… [at a hidden system/Lib/…/SketchUp/… path it creates]

you instal the app and the app installs the driver in system ‘kext’ and a plugin for each SU version…

it is then available from Extensions [although it is badly written and can’t be turned off…]

from reading other post, I believed a similar thing happened on PC’s…

EDIT: this is from a PC user at SCF, but I missed the ‘System’ in his reply…

Then I checked (after all that) the extensions window in System Preferences and the 3DxSketchUp extension was unchecked.


The OP is a Windows user like myself. I have a Space Pilot Pro now, after my Space Pilot malfunctioned. The current driver - which was updated after installing SU16 - installs its stuff at C:\Users\username\AppData\Local\3Dconnexion. It works fine. And back when I installed the Space Pilot Pro driver to run the Space Pilot, that worked fine too.

I haven’t yet installed pre-SU15 on this computer, but I do remember when 3dconnexion dropped stuff in SU’s Plugin directory. But that’s not happening now.

@catamountain, I edited my reply while you where posting…

I had read ’ 3DxSketchUp extension was unchecked’ and assumed SU menu without reading it correctly…


If 3DxSketchUp is showing up in Window > Preferences > Extension, that may be part of the problem. I don’t see that. And there is nothing in the Plugin directory anymore like there used to be.

Try removing anything (file and folder) with 3DxSketchUp in the current SketchUp Plugin directory the OP is using and reinstall the latest driver.

The OP copy/pasted old plugins into a new SU installation?

I am just working as it worked before and I changed nothing. With W10 I can’t do anything. Hate to let the old girl go!

And they cost a lot too. I was forced - kicking and screaming - to upgrade.

This happened after upgrading to Win10? Still drivers should be updated to run under a new OS.

If you have anything with 3DxSketchUp in your SU15 Plugin directory, C:\Users\username\AppData\Roaming\SketchUp\SketchUp 2015, get rid of it and reinstall the driver. It’s old. (You always can drag the old stuff to the desktop or another storage directory if you want to keep it around just in case.)

Oh, and uninstall driver and reboot computer before installing new driver. If this doesn’t work I can hunt down last email from 3dconnexion support - which may or may not for the older Space Pilot. But that sequence did help me get the Space Pilot Pro to work right with new computer using Win7.