3D Warehouse in SketchUp 2017

Due to recent changes in the Chromium embedded browser, we are no longer able to support the embedded web dialog in SketchUp 2017 Make and Pro.

You can still download from 3D Warehouse using an up-to-date browser like Chrome, Edge, Safari, or Firefox, or by using the Components dialog in SketchUp 2017. Thanks for your understanding.

2 Likes

Thanks for the update, and for explaining the options going forward. Can you confirm which versions are affected? I’m seeing a blank warehouse in 18pro as well, but not in 20, I don’t have a working version of 19 to test.

I am using SU Make 2017 and have no components dialog.

So, will there be no fix for this? No way I can upload models from SU Make 2017 to the 3D Warehouse?

I can see how to use web access to the Warehouse and download models, which I can then copy and paste into my model, but this recent change means I cannot do it directly from SU as I was able to do before.

Yes. You can upload them via your browser. Click on the Upload button next to your name at the top right of the screen.

The first post in this thread clearly explains that you can download components from the 3D Warehouse through the Components panel in the Default Tray.

Note that the issue does affect 2018 as well, which no doubt has the same version of Chromium that is in 2017.

OK and thanks. I can see now how to download from the Warehouse, when in SU Make 2017, from the components panel in the default tray. Never used that before. It is a nice workaround, but does not offer the “view all” feature we used to have accessing models using the “get from Warehouse” tool and search.

And I knew I could still upload to the Warehouse when in the Warehouse site using my browzer (I use Chrome.) As I said, it is not as direct as before when the “upload to Warehouse” tool worked in SU Make 2017.

Is this it, going forward, or will there be a fix?

As the first post indicates, there’s no fix available for SketchUp 2017 Make.

I am just wondering if the weird (Extension)Warehouse display reported by some users of the latest maintenance update is related.

Hi. I use SketchUp Pro 2018. Can you tell me if it is the Chromium embedded browser that is causing the problems, why is it not affecting the Extension Warehouse on the set of 3D Warehouse tools? Also would
installing an older version of a browser, Internet Explorer, Chrome etc. or an older version of Windows 10 and disabling the Windows updates make any difference. Thank you in advance.

Maybe I am parsing this explanation incorrectly, but I cannot see how a change could have been made to the Chromium browser that is embedded in SketchUp 2017/18 and installed on thousands of users’ computers. SketchUp 2017/18 itself are effectively immutable at this point, so how can part of them change? Is the “embedded” Chromium browser really a separate component from core SketchUp 2017/18, and an operating-system update on the client-side was able to make changes to the Chromium component?

Or did the incompatibility arise due to a change in the responses from the SERVER-side of the 3D Warehouse?

2 Likes

answer of sketchup (2018 pro)

We understand you are having issue connecting to SketchUp Pro 2018 to the internet, we are currently working towards a solution, and will be creating detailed instructions to resolve this issue that you will be able to read in the SketchUp forum very soon. But we highly recommend to migrate your License to subscription to avoid such issues.

I will point out to my colleagues that if someone opens 3D Warehouse and sees the page, but with most bits missing, their Internet connection is good. It’s that 2017 and 2018 can no longer show the content that is the problem for you.

There is an unrelated issue going on, where 2018 users are being told that there is no Internet connection. That’s the issue that support were talking about. I’ll make sure they know what Peter had said, they will need to make a response that is specifically for the 3D Warehouse issue, and not use the unrelated reply for the Internet connection issue.

Ran across the following in the thread Using 3D warehouse products in 20-20 design software

colin SketchUp Team

5h

Some good news. The issue that had been introduced by changes to comply with more recent versions of Chromium, has been fixed. SketchUp 2017 and 2018 are showing the 3D Warehouse window contents ok now.

For 2020 Design in particular, I found that I needed to go to https://3dwarehouse.sketchup.com/ in the Chrome browser to do the sign in step, then the window in 2020 Design worked ok. You may need to even sign out, then sign in with Chrome.

I launched SU2017 and sure enough, the Warehouse opened up when I clikked the 3DWH button in the toolbar. And it seems that everything loads properly. However, I still cannot sign in - there is still the message “Couldn’t sign you in This browser or app may not be secure. Try using a different browser. If you’re already using a supported browser, you can refresh your screen and try again to sign in.” And of course, if you want to pull a model straight from the Warehouse into SU…you still have to be signed in, just as you do in a regular browser.

1 Like

I tried it, and I could either sign in within the 3D Warehouse window, or I could sign in within SketchUp before opening the 3D Warehouse window. In either case when you sign in you have to use the continue to Trimble sign in option, and sign in with a Trimble ID.

If both signing in within SketchUp, and within the 3D Warehouse window, are both failing, do you have any network security that may be interfering? If possible you could try your phone as a hotspot, and if that signs in ok there is something about your network that is blocking the sign in.

I guess the issue is that I do not have, specifically, a Trimble ID, and that that is the problem?

If you have been signing in with Google, using your Gmail address, it is possible that it isn’t set up as a Trimble ID. When you see the sign in screen inside SketchUp2017, and you have clicked on the continue to Trimble sign in, put in your Gmail address for the Email, and then try to remember what password you would have used. It’s unlikely to be the password you use when signing in with Google, because the Trimble password requirements are tougher.

You can have a practice go at it on sketchup.com. Whatever password works to sign you in there will work inside SketchUp as well. If you can’t figure out the password you used, and if your browser doesn’t have your passwords in a searchable list, you would need to use the forgot password option, then make sure to remember the new password that you set.

Thank you for this good news!

Actually…this didn’t work. When I clikked on the link, I found myself logged in nearly immediately because I was already logged into Google…much like, if I go to YouTube, the page will load and have me logged in simply because I was already logged in to Google. Ended up I had to create a Trimble ID in order to log into the 3DWH inside of SU2017.

Thanks for fixing the problem

Regards

John