3D Warehouse convert to STL


#1

I am a teacher using mysketchup. The school has just purchased a 3D printer. My students have all made a model to print. I have created a simple model of a dice and uploaded into 3D Warehouse to convert to an STL file. I left it overnight & it is still not converted.

How long does this process take?
Does this length of time represent a problem with the model?

Any assistance would be greatly appreciated as my students are very excited to print their models.

Thanks

Paul


#2

It shouldn’t take a long time but it is entirely possible that your model isn’t suitable. Perhaps you could provide a link to the model in the Warehouse so we can see it and tell you for certain.


#3

I found your model and it is not suitable for 3D printing. It isn’t a solid. Removing the stray edge would take care of that.


#4

Wow Dave. Thank you for replying so quick. I have got rid of the stray and am uploading again.

I will post again with my result this time.

Thanks again.


#5

Is there a typical time that it takes to create the STL?


#6

Not sure of the typical time, but you can create an STL file instantly with the free extension.


#7

Except the extension won’t work with My.SketchUp.


#8

…well… Yeah… There’s that…

…

…

If you are ever in SketchUp, THEN you can create an STL file instantly with the free extension.

(thanks for the catch, @DaveR!)


#9

At school we only have SkectchUp Make (2015) or the mysketchup. I have tried to access the extension library via the Make version I can see the STL extension but it hangs up on the sign in screen. Can I add extensions with Make?


#10

try downloading it from the Extension Warehouse in your internet brwoser. Then use Preferences>Extensions>Install Extension to install it. (Preferences is in the SketchUp menu to the left of File.)


#11

Sorry to keep asking questions. My file (and the students) are still converting. I have tried the extension and it says it installs then is not viewable either in the menu where it should be or in the extensions list under preferences. Is it an issue with Make do you think?


#12

Are you looking for it in the File menu as Export STL?

It shouldn’t be an issue with SketchUp Make. Try quitting and restarting SketchUp.


#13

I’ve reloaded its not there.

I wonder if its to do with the installation as its at school and there maybe restrictions.

When I start Sketchup I get these errors


#14

Did you install it with Install Extension?


#15

The Ruby Console error says the STL extension can not find a file named “sketchup.rb” which indicates a botched install of SketchUp itself. Try repairing or re-installing SketchUp by right-clicking the installer and selecting “Run as administrator”


#16

2 Issues I am trying to solve

1: 3D Warehouse is no converting my (or my students files). I put a cube up and it still has the hour glass. I have put the link below.

Cube

2: I have put a helpdesk call in to give me local admin rights on the computer to allow myself to reinstall Sketchup.

Ideally, I want to use the online education Sketchup in the future in conjunction with 3D Warehouse. This is a neater solution for school. So Option 1 is the preferred way to go. I will still try and get Option 2 going as I need to print the kid’s models.

Thanks for everybody’s help.

Paul


#17

Aaron, for school the best way with sketchup & printing would be in the browser. Is there any feedback you get from 3D warehouse about it not converting? At the moment I just have an hour glass after more than a day and one of the models is just a simple cube.

Thanks again

Paul


#18

Also, I had my students upload to 3D Warehouse yesterday & not one of their models is converted?

They all have the tag KCMS is you want to look.


#19

This topic was automatically closed after 91 days. New replies are no longer allowed.