3d text on model


#1

So I’ve created some models with 3d text (non bevelled) on the opjects. I’m constantly importing the models for illustration of how to pack semi trucks. The issue I’m having is that when I import the model, text from 1 specific model shows up on every model ontop of the actual text I import When i open the original file though, that “false” text is not there. Why is it doing this?


#2

Share an example file that shows this. I expect it’s due to the way you have your models set up.


#3

Im exporting as a .dwg


#4


#5

How about giving us the SKP file?

What does exporting as dwg have to do with it?


#6

because im exporting at a dwg, then importing that model into a new file. Its fine in the skp file, its when I import it, it creates this text


#7

660 RAck.skp (708.7 KB)


#8

the file where I am importing the model is to large


#9

Why the heck would you export a DWG from one SketchUp file and import that into another SketchUp file? Why not just import the SKP file or use Copy and Paste?


#10

because it does not import the actual size of the model when I do it that way


#11

There is something odd with the model which I can’t find yet, but you are using layers incorrectly.


#12

If you’re drawing the models at full size like you should be, there’s absolutely no reason the copied component shouldn’t be the right size when you paste it or import it into the other model.

Look at the In Model component library in the file you uploaded. There’s all sorts of unused text components. Since we don’t have your real working file, we can’t see for sure but I expect you’ve got the unwanted text there in the file somewhere. It might be hidden so you don’t see it.


#13

the reason I created the second layer is because I need to name the layer properly so that when I add the item into a truck pack, I can hide specific objects and not have to re create new layers every time I start again


#14

You should not have edges and faces on a layer other than Layer 0.


#15

Im telling you that its not. Stop ridiculing how I do things. I have deleted that text component and it is still present.


#16

But I cant rename layer0


#17

I’m not ridiculing the way you are doing things.

You clearly don’t want help.

I’m finished here.


#18

If I didnt want help, I wouldnt be posting. Im telling you the process I have done, and the problem that is occuring. All your doing is telling me that the way im doing it is stupid, but when I have previously tried to do it the way you are telling me I have other issues arise, which im stating.


#19

I can’t answer your original question because I can’t reproduce the situation you describe using the file you provided. I tried exporting as 3D dwg and importing back into an empty model, and all I got was the original 660 Rack component, no other visible text.

I notice that your model contains 16 other unused components containing 3D Text, among them one that contains your mystery “Jimmy Jib Green Case”. All but two of them have their edges and faces associated with layer “660 RAck”. Liike @DaveR and @Box, I recommend strongly against doing that because it can create confusing issues with visibility. But as you are convinced your workflow is right, I’ll drop it at that.

Were you importing into a non-empty model? I suppose it is possible that this layer usage could be interacting with something if you import into a model with other prior contents and layers.


#20

When importing in an empty file which is first purged, the imported .dwg comes in as ungrouped entities.(eg loose geometry)
If you have ANY geometry in the files(for instance some loose hidden edges) it would come in as a definition with the name of the file (included with the extension)
Is this ‘normal’ behavior?
The imported .dwg all have extra hidden edges on the 3D-text on layer 660_RAck ,not 660 RAck