3D Text does not handle Right-to-Left Text correctly

I’m using SketchUp Make 2015. When I try to create 3D text geometry for a type of sign using Right-to-Left (RTL) text, the text gets messed up. Here’s the text I’m trying to model: مُحِبٌّ جِدًّا

Here’s a zoomed-in image to get a better look at the details:


The text is Arabic using whatever font is default in gmail. (I haven’t tried Hebrew, yet.) Note the diacritics above and below the main characters.

Here is the 3D Text that is generated by SketchUp using Calibri font:

Here you can see that the diacritics are no longer above and below and some are piled up on top of each other! On my other machine I tried this with an actual Arabic font, with no better results.

I tried this on SU 2017 as well with similar results. SketchUp Free on the Web does not seem to support 3D Text at all.

Is this a known problem? Is there a workaround? Does this kind of thing happen with the latest pro versions also?

I now see 3D Text in SketchUp Free on the Web, and I can confirm that it does not handle RtL text, either. Kinda sad for Trimble, since there’s lots of money being spent on architecture in the RtL language parts of the world…

I don’t know if it’s something that could affect the behavior of this tool but sketchup doesn’t support Arabic or Hebrew. There are ways you can have that in 3D though, the easiest one could be to use Inkscape to convert the image of the text you have to vectors, then export it as dwg, import it from sketchup and just create faces to be able to extrude them, you can also create geometry out of a png image this way :point_down:t3:

Thanks, francisquitof, that sounded promising. Especially since I already have a copy of Inkscape on my laptop.

… convert the image of the text you have to vectors…

I’m not familiar enough with Inkscape to know how to do that, but I think it’s probably easier to simply create the text in Inkscape, by copying from my gmail and pasting to Inkscape.

… then export it as dwg…

There doesn’t seem to be a way to do that in Inkscape. There is a menu item for Export PNG image. And there are various formats that I can choose from on the Save as dialog. But .dwg is not one of the options. This is confirmed by the Inkscape Help page: Export Other Formats.

I see an option for saving as .dxf, which I understand is somehow related to .dwg. Would that work for import to SketchUp? Or do I need to use some kind of conversion software…?

There are a few extensions on the SketchUcation Extension Store that allow SU Make to import dxf files.

See SketchUp Plugins | PluginStore | SketchUcation

Sketchup can import dxf files natively, you don’t need to get a plugin for that.

(Sorry for the much-delayed reply - urgent family needs required my attention.)

Apparently, neither SU Make 2015 nor SU Make 2017 can import dxf files. Is that in the current pro version?

The pro version can import dwg an dxf files natively.

None of the Make versions can import .dxf files. That’s been a Pro-only feature formore than 10 years.

I tried Samuel Tallet: Universal Importer, but it would not import my .dxf files created with Inkscape. It said there is no 3D data in the file…

How about sharing the file you imported into Inkscape and the .dxf file so we can see what you are working with?

The file I imported into Inkscape is the image in the original post (at the top).

Here’s what I was able to export from Inkscape: Text2.dxf

Note: I actually, didn’t end up using the image file I imported to Inkscape; I simply created the RtL text in Inkscape, which looked correct. You can copy the text itself from the original post, as well.

It imports fine for me in SU2023 but there’s some excess geometry. I used an online jpg to dxf converter and got a better result. It’s at the top. Your .dxf is at the bottom.

Your profile says you are using SketchUp 2017. Please correct your profile.

I actually use both versions, but mostly 2015, because the performance of 2017 is usually unacceptable.

If it’s not too much trouble, could you save your SU2023 model in 2015 / 2017 format and post it here?


Sorry. I didn’t save any of it.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.