2023 Drape in group

I just installed 2023. I tried to drape some lines on face… it doesn’t work… It works if everything is in the most out model space. It works if lines to be draped are in group. but if I group the face and the group with lines together than inside of this group it doesn’t work…
I go in the context of the group > select the group containing lines to drape them > pick the drape tool > select the face to drape on > nothin > click middle mouse button to rotate view > I can see now the lines being draped and it looks correct > a press SPACE to select some of the new geometry > all of it disappears… like I have done undo pressing that space…
drape3.skp (3.1 MB)
I recreated it in this file so I guess it was not just error in my project… have rules about using drape changed ?
EDIT
right now I need that drape so going back to 2022 till somebody will find some solution…
EDIT
I didn’t go to 2022 I was copying what I needed to out most model space… I just forgot to do it and it worked… with groups being few levels nested… hmm

It works for me in 2023 on windows.

in your model I can drape the line group onto a face
or onto the face (grouped)
I can do that inside the group they are in
or if I explode that top level group, they can drape there also.

I’ve pretty much just got the standard plugins installed with Studio + Enscape right now

Well… Like I wrote it started to work for no apparent reason on Friday… Now I just checked and it is still the same… not draping… is there a sort of info I can send You… or log files… I could record a video or make a giff (don’t know yet how) but it wouldn’t tell You more than I already described, not really a good intel…
Maybe it is just mine PC’s environment… Don’t won’t to burst myself but I got some good luck in making PC things that it shouldn’t be doing… Like system going down first day at work is a standard…

Have you got any plugins installed?

Ye… many… mostly loaded through Fredos Additional Folder Plugin… except for ENScape. So I diseabled Enscape and removed “!AdditionalPluginFolders.rb”. restarted and it is still the same…

Ruby consol says:
Error: #<ArgumentError: cannot remove an instance in the active editing path>
c:/users/user/appdata/roaming/sketchup/sketchup 2023/sketchup/plugins/su_sandbox/drapetool2.rbe:128:in erase_entities' c:/users/user/appdata/roaming/sketchup/sketchup 2023/sketchup/plugins/su_sandbox/drapetool2.rbe:128:in CreateDrapedEdges’
c:/users/user/appdata/roaming/sketchup/sketchup 2023/sketchup/plugins/su_sandbox/drapetool2.rbe:148:in IncrementState' c:/users/user/appdata/roaming/sketchup/sketchup 2023/sketchup/plugins/su_sandbox/drapetool2.rbe:263:in onLButtonDown’

Tested on freshly installed version without plugins… Drape tool inside context is broken in 2023. It just fails to keep the projected result in the end.
Please fix it ASAP.

1 Like

I am experiencing the same thing as push18. For me, the is an essential feature that I use several times per day. Please fix ASAP!!

@dougshaffer a @push18 advised me Super Drape plugin… which I was not going to try at first but some lot of draping came to me…
Edit…
Somehow I can not make it work on 2023 :frowning:

I found work around… When You Drape… there is a moment when nothing seems to happen but rotating view with MMB will refresh the view… before pressing space press [Ctrl+C]. Then press space > everything disappears. Then press [Alt+E] > [A] or choose “Paste in place” from edit menu…
Not sure if it will always copy every single draped line … but should… (it actually does not copy lines but faces around it but it doesn’t matter)

Superdrape won’t work from the start because the author for some bizarre reason disabled it by default. Back to the regular drape… all nice and good but Trimble must fix the bugs that were reported during beta but for some strange reason we’re not. Many other plugins misbehave inside the context and copy-paste workarounds won’t solve it

I mean for me it was easier then copy a group or part of it out to most outside space model… but it does not work properly when draped lines cut some faces on more than two parts… or when they don’t cut it at all… so Ye of course fix is necessary…
Edit
actually this Ctrl+C thing doesn’t work properly in most cases… hmm

Actually Only the lines to be draped (can be in group) must be in out most model space… didn’t notice that at first… that makes it a bit better

In the current state this version is not usable, need to wait till Trimble hopefully will sort “all sorts of problems”

1 Like