2019.2 Layout text

Hi. I am finding that editing text in Layout is really slow. I have tried opening a separate file with just the job specification and no model info thinking that perhaps it was due to the file size I was working on at 35Mb was the issue, but this hasnt resolve the issue. When I double click on the text box it takes an age to open and because of the lag a nightmare to edit. I am running a new computer with an i7 processor and GTC 1070 graphics card which I thought/hoped would solve this issue. Any suggestions gratefully received. Ive attached the two page layout file.
Best wishes
Specification Pages 2 September 2019.layout (218.8 KB)

1 Like

I think you would find it better and easier to work with this text if you create RTF files in a document application instead of adding the text directly in a LayOut text box. Then, when you need to edit the text, right click on it, choose Open with your ‘texteditor’.

Also it is important to note that PDFs seem to have problems with the Bahnschrift font family. It would be a good idea to choose a different font.

Specification Pages 2 September 2019 rev dr.layout (218.7 KB)
Try this one and see if it behaves better. If you haven’t already done so, go to Edit>Preferences>Applications and choose the default text editor.

1 Like

Thanks, just trying to figure out how to make word my default and then will see how it goes. Much appreciate your advice

Browse through the Program Files to find Word’s .exe file and select it.

Sorry to be duh!, but would it be the wordpad.exe ?

You could use Wordpad.exe but I believe you should find Microsoft Office in Program Files and then Word in there. I use LibreOffice and haven’t had a copy of Microsoft Office for years.

I had very slow text rendering in Layout that finally ended up being attributed to a corrupt font. I was using Arial and changed everything in the drawing to Calibri. Worked perfectly afterwards. I reinstalled the Arial font and it works without issues, as well.

That’s a brilliant suggestion. I had noticed that text input was painfully slow in the current version of LO but didn’t think you could do anything about it. I just tried with Calibri (my default was Verdana) and I can type as fast as I like now.

I also have pages of Building Reg text just like @malcymjc but I find creating the columns a bit clunky in LO. I now adopt a solution suggested in this forum a while back which consists of using a word processor (where creating columns and having text wrap automatically is easy), exporting a PDF copy and then importing that to LO. If I edit the word processed document, I export a new PDF with the same filename as before and then update the external file reference in LO. Sounds clunky, and it is compared with a better native solution, but it works well and you quickly get used to it.

Thanks for all the advice. I couldn’t get word to work but Libre Word seemed to work ok. But I noticed if I edited the text a few individual times it then stops giving me the option to edit using the default system when I right click. I tried using Calibri and it definitely works quicker. In future though I think its easier to keep large amounts of text in a separate word document to be issued along side the drawing issue. Labels and short notes don’t appear to be a problem as much as having a large block of paragraphs.
Thanks everyone for chipping in.

As I wrote the other day…

Don’t edit the text in LayOut. If you need to make changes to it, do that in Libre Office. That includes selecting font and size. Editing the text box in LayOut disconnects the text from the original RTF file in the same way modifying a SketchUp viewport in LO disconnects that viewport from the original scene in the SketchUp file.

Hi Dave. Thats what I was doing. I would right click and it would give me the option to edit with LibreWord, then I would save it and do something else. When I went back to the block of text the third or perhaps fourth time when I right clicked it didnt include an option to edit the text with Libre the option was completely missing. The other thing I noticed that when I formatted the text in Libre to multiple columns this format didnt come across to layout. For the future I will still insert word and excel type documents into Layout if needed but generally better for me to keep long specification texts as a separate document which can be turned into a pdf for giving to clients.
Ive been using Sketchup now for ten years plus and every week I learn something new.
Cheers

1 Like

Is it possible that you might have double clicked on a text box inadvertently? That would be enough to do it. Like inadvertently double clicking on a viewport will create a modified scene even if you don’t actually change anything. You should be able to reconnect the text through the References panel if it comes to it.

Columns made using the multi-column function in text editors are a thing that the .rtf format doesn’t support. When I need to make multi-column text, I do create a separate .rtf file for each one. You can crop off text at the bottom of a text box by dragging the edge up over the text. I’ve asked for a similar feature for the top of a text box. This would allow the user to have the text in one long column in the .rtf and create the appearance of multiple columns in LO.

Ah that s an excellent tip thanks. regarding double clicking the box, no I tried it multiple times and I even created a new layout file to try out and as I said it worked fine for the first couple of edits but finally when I right clicked it would’nt give the option to edit the text with the default editor. The lesson may be to do the editing on the root file and relink it if a lot of editing is required.

Absolutely! You should only be editing the root (or reference) file.