2018 Layout dimensions not orthogonal

bug

#1

Since updating to 2018, my dimensions will no longer give me an orthogonal dimension when the origin points are not collinear to the direction of measurement. The strange thing is that the dimension still shows the blue right angle symbol that indicates an orthogonal measurement when selected.

Is anyone else having this problem?


#2

Can you show an example of this? I’ve not had any problem with getting dimensions to line up when off axis. In fact I did two projects over the weekend that both had a larger number of those sorts of dimensions than I usually have and it worked fine for me.


#3

I have just found that I’m having this issue too. It appears that in the Layout 2018 document that I’m trying to work with, the dimension tool is just doing a direct dimension, rather than snapping to orthogonal, when in the vertical or horizontal orientation. In my experience this was not how the tool has worked for me previously.

From the picture below, the model is a 2:3 scale (shown by the absolute 40.0mm dimension at the top, which is not snapped to any model points). When I use the dimension tool between the dark blue point and the cyan point, I get the correct dimension (61.2mm) only if I drag the dimension perpendicular to the length being dimensioned (shown in green). If I proceed to move the mouse such that the dimension snaps to be vertical or horizontal, the number remains 61.2mm rather than snapping to the orthogonal measurement.

I tried to reproduce this error with a basic square and a blank layout document and couldn’t. The orthogonal snapping worked fine. I have no idea what the trigger is, though I have now had three errors on SketchUp 2018 for which I’ve had to contact support for, so am beginning to think that 2018 may just not be for me…


#4

I’m a pretty new user and am not sure if I replied to your query the right way or if you get notified. I’ve uploaded an example in an effort to clarify the issue that is being experienced. Don’t hesitate to let me know if any further clarification would be of assistance.


#5

How about uploading the LayOut file so we can have a look at it?


#6

Hi Dave, I’ve cut the file down, embedded the model and attached it below. If you need the SketchUp model separately/unembedded , let me know.

2018-01-18 - Layout dimensioning Unlinked.layout (2.9 MB)


#7

I’ll take a look. No need to send the SKP file or even embed it. It comes along with the LO file either way.


#8

Are you really trying to dimension diagonally across the neck of the bottle shape? The actual diameter of the opening is 60.00mm not 61.2mm.

You’ve got some edges hidden that would be useful to have displayed in the SketchUp scene and because of the cylindrical shape of the neck, you have some vertices on the circle that appear very close to the ones you really want to dimension to. If you zoom in very close, you can make sure you are applying the dimensions to the right points. If you were to dimension the section cut slice, you could make things a bit easier but there’s no reason you can’t get the right dimensions from what you’ve got.

The dimensions shown below match your Sketchup model’s dimensions.


#9

Hi Dave, the pasted example is just an example of the problem. If I click the dimension too and snap to the points shown by the navy blue and cyan circles, as I move the mouse around the dimension points, it just keeps the same dimension, 61.2mm rather than snapping orthogonally to 60mm when vertical, and 12mm when horizontal, as you’ve correctly shown. Am I right to say you’re not getting this problem when you open the model? Perhaps I can try to take a quick video with my phone and upload it to clarify?

I had thought that hidden and small line differences may have been the problem, though I did a section cut, made a group out of it so that it was just a 2D basic line drawing, and I got exactly the same issue.


#10

OK. Now I understand what you are getting at. The 61.2 dimension is the diagonal distance and the Dimension tool will display that dimension no matter where you put the dimension arrow. I expect that should not be that way. @trent, thoughts?


#11

Yep, that is spot on. It seems to give me the the diagonal dimension, even when the Extension lines snap to horizontal or vertical, at which point I would anticipate layout to give me the equivalent orthogonal dimension.

Does it display this behaviour that I’ve described when you open the layout file that I’d uploaded? Or when you look to take a diagonal dimension, does it give proper orthogonal dimensions when vertical or horizontally aligned, as expected?


#12

No that should not be the case and I am looking into this in more detail.

I will let you know what I come up with.

Trent


#13

Hi Daniel, I think I have figured out what is happening and this is not new behavior to 2018, I see the same issue in 2017. We made improvement in this area in 2018 not to pass the z height of varying entities but the reason that LayOut is displaying dimensions like this is that the view is not parallel to the axis. When this occurs LayOut believes you want to dimension the actual dimension.

I noticed two things that tipped me off that this was what was happening.
First, LayOut dimensions should display rt angle marks on dimensions when dimensioning in parallel axis. Dimensioning the model and selecting the dimension did not produce these marks but a diagonal dimension.

The second thing I noticed was that the section plane appeared to display ‘double’ section marks on top of each other in LayOut.

I opened the model in SketchUp at the current scene “Front - SecCut5 - Sparge Outter” and verified that I was seeing double. :0)

I then zoomed out without obiting the view (middle mouse wheel scroll) and noticed that the a green axis was going diagonal even though the view was in parallel projection.

I turned on the Layer C - Section 5, entered the component, rt clicked on the active section plane and selected ‘Align View’. The section marks now displayed correctly and the axis displayed parallel.

I then Updated the Scene, Saved the file and Updated the model reference in LayOut.

The dimension will now display the correct distance and selecting it will display the rt angle mark.

Please let me know if you have any questions or need any additional clarity.

Trent


#14

That is superb Trent, thank-you so much. You’ve just saved my whole Sunday from trying to dimension from inferred parallel points!

I’d seen many of the things you noted, such as the non-parallel section marks, the diagonal green axis, but hadn’t been able to work out how to fix it. Thanks again, I really appreciate your time and expertise (and DaveR who also was a big help in getting to the root of the problem).


#15

Hi Dave,

This is the problem I am having.

In This first image the dimension origin points are relatively orthogonal to each other. Notice the blue 90 Degree indicator.

In this second image I have moved the upper origin to the corner. The blue 90 degree indicator is still there but it is giving me a different dimension.

If I pick a point further away but still on the same parallel line I get a more dramatic example.

The dimension should be giving me the length of the dimension line (the one with the number on it). Instead it appears to be giving the diagonal dimension from origin point to origin point. Before 2018 this difference in measurement method was indicated by the blue square but now the blue square seems to mean nothing.


#16

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.