2017 Extensions not showing up


#1

I have been using 2017 for a while, but I cannot get my extensions to show up in the Extensions tool tab at the top of the screen. The extensions appear to be correctly installed and enabled in Extension manager, but only one out of the 6 or more installed extensions show up in the Extensions tab.

2016 worked fine, and all of the extensions showed up in the Extensions tab.

WTH?


#3

The extensions showed up in the Extension Manager, so I’m pretty sure they are installed. They were all installed in 2016, and they seem to have automatically transferred over to 2017 when I installed it.

My username is already an administrator


#4

As I said, some of them are there, some are not


#6

Well, they did automatically install. As I said, they are in my extension manager, and show up as properly installed and enabled.
I did not install them, they were just there after I installed 2017.


#7

Other than this one little issue, Sketchup 2017 performs flawlessly, so it can’t be an installation problem.


#9

Try to keep a civil tongue in your head.

Do you think I am an f-ing moron?

I just uninstalled 2017, and reinstalled it by clicking “Run as administrator” with EXACTLY the same results. All of the extensions I had installed before AUTOMATICALLY SHOWED UP IN 2017!!!

I did not re install ANY extensions, yet they are all there. HMMM. How can that be???

Twilight Render and Flights of ideas showed up in my toolbar just like before, but I still do not have Guide Tools which is the one I really need. It shows up in the extension manager, and the only option I have is to uninstall it. That pretty much means to me that it IS installed.


#10

Do you see a Sketchucation extension in the extensions menue?


#11

No, sir, I do not.


#12

are any of the missing extensions listed in your tools or draw menues…or in your right click menues?


#13

No, they are not in the tools or draw menus, nor are they in the right click options.


#14

The Twighlight render plugin has a toolbar set of icons, as does the SVG export utility, Flights of Ideas Tools. Specifically, Guide Tools used to have several options that show up in the extensions menu, but are not there. 2016 still has them.


#15

but you say they are listed in the extension manager?


#16

Yes, they are.


#18

Try installing them with the install button at the bottom left in the manager.


#19

I just uninstalled Guide Tools. I forgot there was a prerequisite library that I had to install first. I installed that (TT Lib2), using the install button, then Guide Tools, also using the install button. They do not show up in Extension Manager.

So, I went to the Extension Warehouse, and tried installing them from there. It says it was succesful installing both, but the button on the Top Right of the EW still says install. Normally if an install is succesful, it changes to uninstall. Programs are not available on the Extensions menu.

I am going to contact the author and see if he has any ideas.


#20

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.