Why sketchup does not save file every 30 minutes?

i have 15 minutes autosave in sketchup settings but…it does not work at all. What is wrong and how to fix it? The software does backup randomly every 2-3 hours without any sense. Does not save files at all only manually. Any help? Can i set backup time interval? in settings there is no place for that.


you screenshot clearly shows the back up time interval and it is set to 15 minutes.
It won’t autosave unless you make modifications to your file.
right now you have an autosave of an autosaved file opened (which is kind of wrong), you should save it as a new file with a proper name if it is the most advanced version, and if you are at some point led to open an autosaved of if you are warned that the model you are trying to open has a more recent autosaved version, you should save it straight away as another file.

You are working with pretty big files, make sure you’ve purged them going to window > model info > statistics purge unused before saving.
setting up autosave every 5 min for a >1Gb model can be a pain in the *** since it’s going to take time to autosave

A backup get’s created upon opening a file (When checked) It is the state of the model as saved the last time.
Each manual save (eg. Cmd S) will set that backup file to the current and while you move further with modelling File->Revert will get you back to the last ‘Save’

If something goes wrong, you will have autosave as backup (pun intended), but there is only one autosave while working, each interval replaces the last! (clock starts counting when you actually edit the model)
If you forget to save or SketchUp crashes there should be an autosave file that represents the state of the model of the last interval when opening SketchUp.

If you want ‘versions’ use the ‘Save As feature’ or publish to Trimble Connect.

I noticed you were using Vray. If you expect sketchup to autosaved while you’re working inside vray only (such as changing rendering parameters, material adjustments) and not modifying anything on your model in sketchup, don’t expect it to autosave !


1 It does not auto save regardless wheather it is basic file or autosave
2. i dont get - i wish to have the file automatically saved every x minutes.
3. as far as i imagine backup - creating autosave file is different story innit?

What to do to have the basic file beeing saved automatically not backuped?

Hi - but i dont get very basic thing - how to set sketchup to save my basic file automatically.?

At the moment it only saves manually. Autosave is as far as i see it a different story - separate file to create backup. ! so create backup means - create autosave file? save every x minutes - it should save the basic file? yes? but it does not do it…

Zrzut ekranu 2020-11-22 o 15.36.03|690x456

The Autosave function doesn’t touch your original file. It creates a temporary file in the designated autosave location. If SketchUp crashes, you can retrieve your unsaved changes from the autosave file. When you quit SketchUp, you will be prompted, as usual, to save your unsaved changes. This will overwrite your original file. When SketchUp is closed, the autosave file is deleted.

Hello thankx for answer. So what is it for to set time interval for autosave? If it only saves oryginal file manually while closing? It should work and save - overwrite the oryginal file every x minutes isnt it? What about backup file? If autosave should save every x minutes the autosave file not oryginal what backup file is for and where is it?

Are you sure that sketchup allows to save oryginal file only manually? It makes no sense to me really

To me it makes. I often make what if-type changes to my models that I finally discard. So for me what is saved must be what I want to save. I don’t want to save my mistakes.
I have turned autosave off in all applications that have it. I use the ctrl-s shortcut as often as I can. Application stability has generally improved in this century so that it has been very, very long since I lost any data by a crash with an unsaved document.

1 Like

Automated saving is not enabled, however, if you really feel you need it then it’d be relatively simple to write a short Ruby script which saves the current model every 15 minutes - it just need a persistent UI.timer setting up and the model gets saved regularly, whether you want it or not.
I suspect you’d soon get very jaded and disillusioned with it, because like AutoSave it could kick in at an inconvenient stage of your workings and mess you up by grabbing focus etc… This is one reason most users set AutoSave off in Preferences, but keep the backup on, as if things crash then you only loose the changes since the last manual save…
If you do write such a tool you could easily have options to switch it on/off and change the save-time etc…

1 Like