Why sketchup 2024 can notrequire zlib.so


Hi everyone
I am a developer of plugins and I am using Sketchup2024 Simplified Chinese version. Why can’t I load zlib?

Something to do with the username path and not being valid UTF-8?

No,my Windows username is English

I am running on an English system, with SketchUp set to “en-US” localization and can load it:

require 'zlib'
#=> true

Zlib
#=> Zlib

Can you load any other *.so files, like openssl, psych, josn, etc?

Many people are running Windows 11 or 10, I don’t recall what sort of encoding issues older Windows versions have…

Depending on whether you can load other *.so files, would you be willing to try a stand-alone Ruby (similar to SketchUp’s Ruby) to see if you could load zlib, etc?

SU Ruby jumped from 2.7 to 3.2, there’s a lot changes, and I would think that encoding issues would decrease with later versions…

Thanks,I have already solved the problem。

Thanks,I have already solved the problem!

Glad that you fixed the issue.

If you’re comfortable sharing it, and for everyone’s benefit, what was the cause?

Or, having an ‘EN-US’ system, I’m always interested in encoding problems and solutions…

My C++ installer for my high end panel optimizer has been using ZLib for many years and worked just fine until recently where the compressed file was told it was a virus.

I switched from ZLib to Zip (alas it is bigger now) and my new install file is no longer tagged as a virus.

was told it was a virus

Interesting. What software generated the notification?

using ZLib for many years

Do know what version of zlib generated the notification?

Since stand-alone Windows Ruby uses it, I’m surprised the issue hasn’t appeared elsewhere.

I use Inno Setup version 5.6.1(a) for my installer.

Windows 11 on one of my customer’s computers generated the false positive for a virus.

RubyInstaller2 (the main source of Windows stand-alone Rubies) uses Inno for its ‘setup’ program, but there are also 7z ‘packages’.

I don’t see any ‘virus’ issues opened in the last several years. I wonder what caused the false positive…

Yes, please tell us the solution.