Why is this not a solid?

I tried to use the intersection tool on this and I am being told it is not a solid. All I did was use the push/pull tool. I am attempting to use the intersection tool to make holes in things and subtract solids from each other and add them, but every time I try to use any of the solid tools I am told it isn’t a solid.

None of the answers on the fora here seem to apply to sketchup on the Web; all of the answers are for people who upgraded to the pro versions. I tried “entity info” but the interface looks nothing like any of the examples. Please help. This is getting really frustrating. The links to “Sketchup for Dummies” aren’t helping either – so please doin’t suggest that.

. ooga.skp (217.7 KB)

Thisis what the “Entity info” looks like on my version of sketchup; I can’t figure out how to tell if it is a solid or not from this

And it’s not, because it’s not even a group. Select the raw geometry (triple click) and right-click Make Group. Do the same for both forms.

1 Like

Thanks so much! So many of the answers to questions about solids omit this step and you are so far the first person I have seen who answers a Q that applies to the web version.

1 Like

The thing about solids is not specific to the web version.

In order for SketchUp of any version to consider something a solid, it must be a group or component. The group or component must contain only geometry–no other groups or components–and every edge in the group or component must be shared by exactly two faces. No more and no less. So no stray edges, no holes in surfaces, and no internal faces.

If you look through the various SketchUp for Web categories, you’ll see there are many others who also answer questions regarding the web version.

1 Like