Why does sketchup do this?

Why does sketchup do this? How do I remedy it and is there a term for this rendering issue?

See image:

It’s called z-fighting and occurs when two faces are fighting for position.

How do you fix it? It was inside of a component this time and occurred when I combined a face that was split by deleting a line that separated them. When I delete the face, multiple faces that are behind other lines also disappear. As for are I know all lines are on the same plane. Still trying to understand how to fix and avoid future occurrences.

You will normally get z-fighting when you put a group/component onto a face.
What happens is the face in the group tries to occupy the same point in 3d space that the single face is occupying. This causes your computer’s graphic system to show one and then the other which makes the flickering double colour effect.
Even two groups together will get it, it is the nature of the beast.
Things in 3d do not work like they do in 2d, you can’t say something is in front of something else, you need to physically place it in front.
A simple example for you, make two cubes and place them touching, then go inside and see what happens to the two touching faces.
So in situations where it happens and you don’t want to see it you need to either remove one of the faces or put some space between them.
As for multiple faces disappearing it sounds like when you deleted the edge you may have deleted a group or component or in some other way altered the geometry, without see the model we can only guess.
Feel free to add your model so we can be more specific.


Thanks for the detailed clarification on this - it does make sense in the situation of grouped items touching the same space. It is helpful to know the cause in working through this. The model had since been altered and was no longer acting up. I like that groups don’t auto-join each other. Especially when working with lines that intersect roof to wall sections, is there a way to specify “on-top, front or back” placements within a model? It no longer sounds like a user error problem, but it certainly an annoyance, especially when adding materials to an elevation to showcase proposals to clients.

There is no in front, etc., because the meaning of such phrases depends on the direction of view. That changes when you orbit the model. In front becomes in back when you look from the other side!

With components, there is the option to “face the camera”. Was hoping there was an additional setting there to give a top priority to the desired battling plane.

That is not really possible in a general 3D application.

It might be, but would be equivalent to hiding the undesired one.

1 Like

The desired component definition can have its cutting property set.
An instance can then be placed on a face and it will cut a hole in that face, avoiding Z-fighting altogether…
But all of this begs the question why are you modeling two faces which overlay each other like this, and thereby cause Z-fighting. The one you don’t want can be deleted without any loss ??

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.