Why does my VRAY render look different when I export?

Hello I am creating renders for a bathroom project. When I render the image looks great on the screen but when I decide to export it gets too white. Any help would be appreciate! Attached are the images from the screen view to the exported view.

After exporting Image

You can try exporting as tiff format…

Do you have some automatic postprocessing filters set up? Exposure?
Are you saving the “current channel” or something else?

1 Like

I am saving the current channel and that is how it appeared. When I lower the exposure by a number it gets either really dark or very bright like the picture. Where can I check the automatic post processing filters? Thank you!

Please show a screenshot of the vfb.

This is another view I am rendering using the same settings. This is the VFB?

first thing, check Display Correction on the right and ensure the exposure is set to zero.
There are no automatic post processing filters set by default, only what you set in the preset layer stack.
That should ensure what you see is what you export.

This may not have a bearing but just bear in mind that when you save out the current channel, unless you select something like a .exr or a .tif, a .png or .jpg is an 8bit per channel image.
The vfb displays in 32bit float so saving the current channel in png or jpg will effectively lose colour and tonal information as it will be crunched down to 8 bits per channel. Most of the time you wont really notice but if the image is tonally within a relatively narrow range, showing smooth flat gradiation, it may have an impact. Although your example does look like an exposure issue to me.

Both support 16,777,215 colours.

How can I save the vfb in 32bit per channel image?

Thank you for your help!

Is there anyway to save it at a higher bit per channel?

As said, probably there is no difference. Can you post the model? Can you post a screenshot of your V-Ray settings? What if you revert to the default render settings?

What format were you exporting your render? What application was the screenshot from the exported image from? Is your image editor applying a custom profile or some autocorrection?

save as .exr in the save options.
check your Display Correction exposure first, it looks like exposure to me.
Although saving it as 32 bit .exr will allow you to accurately tone map it in photoshop without having any exposure ‘baked in’.

This is the exposure setting that is currently on.

OK so that’s the reason. This setting here is purely for display purposes (what you see in the vfb) it disregards this setting when exporting.
Add a new Exposure layer in this stack, set to the same value as you have here, reset the Display Correction to Zero then when you export it should be the same.
If you just modify the parameter in the Exposure layer, what you see is what you should get.