Why are my objects getting attached to each other?

Select Draw/Shapes/Circle

stretch out a circle across a sphere face such that it intersects the sphere
select move object and then drag the circle outwards
moving the circle pulls out new material from the sphere, destroying the simplicity of the sphere

how do I disassociate the circle from the sphere so that they are NOT glued together, and then they stretch together?

This program is definitely a lot cooler than at least 3 other major ones that I have looked at

thanks much!

I’m no expert but if you make each object a group or component that won’t happen. Right-click and make your choice.

That is a basic design concept of SU. Components and groups are used to isolate geometry, layers are then used to control visibility of those. My personal bias is to use components.

1 Like

Until you make your selected geometry a group/component, they will stick/merge with any other loose geometry that it comes into contact with.

Yes, double click on your object so it`s edges and faces are blue. Then right click on object, it will give you the choice to make a group or a component. This will prevent it “from sticking” to the other geometry but you must remember that in order to modify it. You will need to double click it again, this is called opening to edit. It will let you move, copy and scale it without opening it up, but you will need to see the “bounding box” grayed out to change the size or add /subtract from it. There are different traits between the group and components beside make them isolated instances and get to know them. They will save you a lot of aggravation and a must to know when working with layers or how they effect extensions and the modifying tools. LEARN them…


This will give you a great deal of info about them and use the Concepts and User`s Guides to get all the info and practice you can. Without them you will hate the program…Peace…

thanks everyone for the great replies

I definitely use groups and components, but I wasn’t aware that without them things smear together.


You’re encountering a feature call break edges. It was added a few years ago as a feature the developers always envisioned for the program but weren’t able to add until a later date. There are at least two plugins that will disable break edges. The other plugin is at Smustard.com.

Some methods of work, work better the old way. Back then, we had to select the geometry and intersect.

A modest amount of study will raise your awareness
Groups and Components

Many more here…
SketchUp Video Tutorials … SketchUpVideo Channel — YouTube

thanks CataMountain…very interesting information.

What else do you know?


I know a lot. Such an inquiry needs more focus :eggplant:

OK catamountain, I’m about to post a new difficult one that isn’t mentioned in the manuals, maybe not possible