White screen when going to (some) scenes in Parallel Projection - Sketchup 22

did the steps work ? can i try ?

Would someone be so kind as to write a script snippet that fixes active scene camera ?

Basically, switching to Perspective, and back to Parallel Projection, brings the model back into view.

Thanks Anssi though the alignment of the view then is changed, which means that all the work in Layout is messed up.
I ended up deleting some larger geometry and the problem goes away. Not that I want to delete that geometry

The problem file I had kept its view crops in LayOut, contrary to what I feared. Try it - I wonder if mileages vary.

Thanks Annsi,
Upon further investigation, I have realised my various other attempts to fix the scene was messing up layout.
I confirm turning perspective on then off, and updating the scene fixes the problem. I do note however that even though layout will show the scene at the correct former position, in sketchup the scene may be at a different zoom level than it was before, though still ‘centered’ in the same location.

This is a huge issue for me as well. Whiteout has happened in 90% of my scenes.
Any any active sections turned off in 2022 there were active in 2021.

benarimcdonald -

I totally agree. This is a huge issue and has affected several of my active projects. The work-arounds and script that Colin posted work for one of my projects but not the others.

Doug

Would you like to try the script work around on your file?

Yes that would be great Colin, thank you.
It’s just a bummer I’m on a deadline and have very limited time to trial and error solutions. I’ve already spent a solid day just resetting scenes and viewports and annotations, dims, etc.

Colin, the script seemed to work on ALL of my viewports, thank you!!!
I tried turning scene transitions back on afterward and it seems to work fine. Can you confirm doing that is okay?

Yes, that’s ok. Scene transitions need to be off while the script is running.

1 Like

I’m having this same issue, and use Layout for my CDs, so this is a HUGE problem - will there be a fix soon???

The fix may not be around for a while. I will direct message you with a work around.

I’m having this problem too with all my projects. I’m following 2 posts here, but I see no solution. The only solution for me is revert to Sketchup 2021 where everything still works fine.
I’m bumped that there will be no fix soon. This bug is HUGE and Sketchup 2022 is useless now. I hope it will be fixed very soon. I paid for Sketchup 2022 but I can not use it.

This is killing us guys…we have large models with lots of scenes and the re-work this is creating tons of extra work on multiple different projects…