When I create a new component or group and paste it into one scene, it appears in all my scenes

I have used Sketchup for a long time but this is my first attempt at drawing a complete house to send viewports to Layout to create permit drawings for the building department. I have learned all these steps but I can’t figure out one pesky problem.

The entire house is drawn with separate groups for Foundation, Framing, Drywall, etc. I have also created many Scenes showing various parts of the house ie. First Floor Walls, Second Floor Walls, etc. by selectively enabling/disabling visibility of components or groups of components I don’t want included. I use the visibility eye in the Outliner to select or deselect them. Everything works great except: If I select one of my scenes and draw a new component or group of components -say- I create an additional wall in the First Floor Walls scene, when I switch to the Second Floor Walls scene, the new wall shows up there as well, and all other scenes I have created in addition to that.

I think I must be grouping incorrectly or something. I want to add a wall to just one scene.

Does my explanation make sense? I have searched for weeks to find an answer but haven’t found anyone experiencing that exact problem.

Scenes are not just static views of the model as it was at the time the scene was created. Think of the scenes as live camera views that will show you the current state of the model. If you add a couch to the living room, the couch will show in every scene that shows that part of the living room.

What are you doing for the second floor scene to not show the first floor walls?

I think you are, too. Or at least managing the groups incorrectly.

If you share the SketchUp file with us we can give you specific help.

Thanks Dave,
I am brand new to posting problems here. I could muddle around figuring out how to share my file but why don’t you guide me on how to do that first. It is a big file (I presume).

I tried dragging and dropping it but it errors out saying it is too big.

Upload your .skp file to a file sharing service like Dropbox, OneDrive or WeTransfer, then paste a link to it your next post.

To make sure it isn’t any bigger than it needs to be, go to Model Info/Statistics [Purge unused], and resave the file before you upload it,

I create the second floor scene by deselecting the visibility of the first floor walls in the outliner window. Alternately, I deselect the second floor walls in outliner when creating the first floor scene.

Thanks John.

Instead of Hiding the elements that way, you should be giving tags to the groups and components in your model and using them to control the visibility. If you have a tag for first floor walls and have turned that tag’s visibility off for the second floor scene, any new wall groups you make and tag with “First Floor” will also be invisible in the second floor scene. You could add as many wall groups to the first floor as you want and as long as they are all tagged with the first floor tag and that tag is invisible in the second floor scene, those added groups won’t show. Save Hide for temporarily getting something out of your way. Use tags for hiding stuff for scenes. That will make your model management much easier and, when you get to LayOut you can use tags to control object visibility there which should allow you to reduce the number of scenes you need to create in the SketchUp model.

Looks like it would help to start by learning how to use tags correctly. ALL edges and faces should be created and remain untagged. Here I’ve fixed that issue in your model.
Screenshot - 8_10_2022 , 12_23_52 PM

Purging unused stuff is also a good idea. This reduced the file size by more than 50%.
Screenshot - 8_10_2022 , 12_25_19 PM

Thanks Dave,
I will have to study your suggestion a bit.

I started (months ago) creating tags but got confused between them and outliner. I abandoned tags altogether and switched to selecting visibility in outliner. I have since watched a video on how to use them properly but haven’t yet gone back to clean up the mess that is in the tags window.

I will have to sit with your response for a while to understand it.

I am not sure what you mean by leaving all edges and surfaces untagged. I may have messed this up. My current understanding of tags is to apply them to ‘types’ of groups or even types of components. I don’t recall assigning tags to just edges or surfaces.

It’s defintely easy to let things get out of control if you don’t clearly understand them and when your model gets to be as complex as yours, that out-of-control-ness can get to be very complicated to fix.

In reality using tags (and tag folders) should be quite simple and straightforward.

Something happened somewhere along the way considering how many edges and faces have tags in your model. One important thing to remember is that the contents of a group or component inherit that group’s or component’s tag so exploding to raw geometry would result in the edges and faces being tagged. You shouldn’t need to explode to raw geometry very often but when you do the very next step while the geometry is still selected should be to remove the tag from the geometry in Entity Info.

I didn’t know about the problem with exploding components but that makes sense now that you point it out.

1 Like

Well, I guess I just needed to state the problem to comprehend what was wrong. Nothing was wrong. It was my basic misunderstanding of how things display combined with a whole lot of stuff in one drawing.

It was as you said, the way I am hiding/unhiding things is bad practice. I have components nested several levels deep in Outliner. If I wanted to hide something in a scene I randomly hid either the component itself or the group it is in. That’s a bad idea. If I hide the component but leave the group visible, anything new I put in that group that is visible pops up in every other scene that includes that as a visible group.

I suppose I should either hide groups only, in Outliner or hide Tags but avoid hiding components within groups. Does that sound right?

I find that the best practice is to use Hide as a temporary thing while I’m modeling but for object visibility control related to scenes, use tags and tag folders. This applies to both groups and components.


I had this problem again. I created a component in one scene and it became visible in other scenes. I found how to stop it from happening.

  1. I create a component in any group and it is automatically visible in Outliner (otherwise I could see to create it).
  2. I Hide it in the Outliner window.
  3. Cut it from the model entirely (Hidden)
  4. Past In Place

Now when I look in all the other scenes, it is not visible in any of them

  1. I go back to the scene that I want the component visible and make it so.

It remains “as pasted” hidden in every other scene as well.

Sounds like you have a process that works but it’s a lot of extra work that you don’t need to do.

I don’t doubt you there Dave. If I weren’t so close to printing and submitting the drawings I have made from this Sketchup File I would fix it as you have suggested. Once that is done I want to make a copy of it and then I will have time to fix it and regroup it as you have suggested.

If you use tags correctly and the group is assigned to tags that are set per scene, you won’t have this issue.

1 Like

I am wondering if, since using Outliner to group/hide is a newer feature, most experienced users have always grouped and hidden/displayed with Tags (what used to be Layers). Along comes Outliner and there are now two ways to do the same thing.

This really feels like a design glitch to me. If I create a component inside a group using Outliner, it shouldn’t enable itself to be visible in all other Outliner groups. By hiding it, cutting it, pasting it back in place and unhiding it a group it no longer appears visible in all groups.

Maybe it’s not a glitch and there is a very specific reason it happens. Sketchup is a very complicated program and I am proficient at maybe 20% of it’s capabilities.

I prefer to use Hide as a temporary thing while I’m working and tags for object visibility for scenes. For me, anyway, that’s much more efficient and with tag visibility control in LayOut, I can manage with many fewer scenes than I would need if using Hide.

Outliner is not a replacement for using tags. The advantage of tags and scenes is that you can set up templates. So once setup, you don’t run into these issues ever.

Using outliner solely as a means for visibility requires that process through outliner for every project. It will severely impact the speed to produce a project.