Walkthrough using game engine

Here’s a simple realtime 3d walkthrough using the Unity 5 game engine which now has realtime global illumination right out of the box. Interested in your thoughts.

It’s an executable that runs on any Windows PC: http://structural-designer.co.uk/wp-content/uploads/2015/08/Realtime_global_illumination.zip

The download process is too tough. You have to ignore some number of other things the page wants to install, then give an email address for them to send the download link to. Could you not just post the file here?

1 Like

The maximum size for upload is 10Mb and his archive has 20Mb, i think.
I don’t know if 20523296 is 20523296 KB or MB
Anyway, the choosen filehoster is not easy to use inside a forum.

Maybe mega or dropbox be better. Easy to click and download. And the file does not expire.

Hey Colin! – How’s things? Sorry about that; I just used the first file hosting site I found on Google. I’ve uploaded it on my own site and hopefully there’s enough bandwidth.


I tried making a folder, didn’t help. I expect it needs to have something in it!

I clicked on your icon, to realize what RDJ stood for! For anyone else who cares, I was a tech reviewer on two of Robin’s SketchUp books.

Me too.
Extracted from Unity 5 documentation » » Building standalone players

“… For the Windows build target, an executable file (.exe) will be built, along with a Data folder which contains all the resources for your application. …”

Oops :laughing: Sorry, I assumed that folder got unpacked by running the .exe. I’ve now added the folder to the zip file so it should work.

If this doesn’t work I’ll set it up in the web player instead.

For anyone else who cares, I was a tech reviewer on two of Robin’s SketchUp books.

Yes, you were great, and then I think you went on to write your own! :fist:

Thanks, for the zip and the comment! I went on to write a book for the same publisher, but not about SketchUp.

Unfortunately, mouse look doesn’t work for me, with either a mouse or trackpad. I could only look at the two windows. Those still show off some of the look of Unity 5, but not really the potential of roaming around a whole house!

I am really impressed with the things made with real time engines.

Your job is very good but i saw somethings worrying walking through the room:

  • The exterior light pass through between vertical and horizontal objects. Ex.: (wall and floor, etc.);
  • Bloom effect is more intense than real life;
  • On QuixelShaderSetup Configuration window, no matter which option i choose on Graphics quality, the appearence and the performance of the walkthrough remains the same.

I believe the build settings is not full.

1 Like

Great idea - some (most) of the next generation game engines have fantastic lighting and surface rendering capabilities: would love to be able to utilize them for viewing and walking around sketchup models. Would be really nice to ‘publish’ an exe to a client for them to walk through on their own.
(The best solution I’ve found so far is Sketchfab)

I would like to see a little bit more complex model with other surfaces. (I jumped out the window and fell into the void…)

I agree with anme: the joints between surfaces “bleed” light. There also seems to be a bit of a glitch with some of the shadows in the window openings - they look too dark.
I think that the Bloom is only up so high because you can see into the shadows - turning down the volume of the light should deepen the shadows and not make the bloom so pronounced.

Personally I would prefer a smoother navigation rather than the ‘stepping’ effect - but I presume that’s just the way that the engine is set up.

1 Like

In case you haven’t seen it, take a look at this video:

It’s all real time playback in Unity, though I’m sure they used the most powerful setup they could find! Still, it shows that environments can look a little more interesting than Robin’s example.

1 Like

Great points. This is just a simple example using only a few rectangles extruded to form walls and windows, so by no means is it a showcase. I haven’t been able to get rid of the light bleed on models imported from SketchUp which is ultimately why I’ve given up on Unity for now.

Don’t give up @robin! Because of you i began on study Unity. Your bleed issue seems a option that you don’t have ticked.

Make sure that your options are the same as mine.

I don’t remember having seen the Normals/Tangents settings, so that might solve the issue. Thanks for pointing it out!