VSCode Ruby extension no longer mantained

If you’ve been using VSCode for Ruby work you’ve probably used the Ruby extension by Peng LV.

This extension has recently been deprecated in favour of a new one ruby-lsp.

Unfortunately, the old one supported debugging via the rdebug-ide protocol that the Ruby SketchUp debugger tool uses: GitHub - SketchUp/sketchup-ruby-debugger: Ruby API debugger for SketchUp 2014 and later.

I’ve asked the mantainers of the new extension if this protocol was on their road map, but unfortunately it’s not.

This unfortunately makes it hard to setup VSCode to debug against Ruby in SketchUp. I’m not even sure if there’s a way to install the deprecated VSCode extension any more.

We currently don’t have capacity to look much deeper into this right now. So if the community has any solutions that would make VSCode work with rdebug-ide, please let us know.

I have not tried this solution yet:

I have this working for edit, but it does not support the debug ide.

2 Likes

Wow, this is bad news!

I’m trying to figure out the best alternative. RubyMine is a paid subscription, and Aptana doesn’t seem to be maintained anymore. NetBeans maybe? Has anyone set up a new debugging configuration successfully yet on any platform?

Earlier I had NetBeans set up and working. As I recall, it was a lot more effort to set up and use than VSCode, which is why I switched over.

It seems like it may be the only option standing for macOS, since I believe Aptana won’t run on ARM.

I have tried a couple Ruby debug extensions in VSCode and couldn’t get them to work. They would just spin forever waiting to connect to SketchUp. My suspicion is that they want to connect to a running instance of Ruby itself and don’t understand what SketchUp is doing. But I admit that I really don’t understand how they are supposed to be configured nor their relation to the ide protocol. Someone with deeper insight might be able to make them work.

You can install the previous ruby in vscode
“Ruby for Visual Studio Code”!
See:
https://stackoverflow.com/questions/42017617/how-to-install-vs-code-extension-manually
You Can Download the “rebornix.Ruby-0.28.1.vsix” on:
https://marketplace.visualstudio.com/items?itemName=rebornix.Ruby
Look for the link Download Extension

3 Likes

I tried this yesterday. I was able to load the older Ruby extension easily, but the debugger isn’t attaching. Maybe some dependency is now missing or something? Has anyone gotten this to work, by reverting to the older extension after VSC had automatically updated to Ruby LSP?

It works for me. I have first uninstalled Ruby LSP!

I did that too. Will give it another try…

please look at!

Visual Studio Code Frequently Asked Questions

Opt out of extension updates

    "extensions.autoUpdate": false

or

    "extensions.autoUpdate": true
2 Likes

Thanks. For now the problem is not that Ruby LSP is getting auto-restored. It’s that after restoring the previous Ruby extension, I’m finding the debugger doesn’t attach (even though I can launch SketchUp with the rdebug args from my previous configuration). But thank you. I’ll figure it out.

It turned out I needed to reinstall some dependencies. This link may help if anyone experiences the same thing: https://github.com/rubyide/vscode-ruby/blob/main/docs/debugger.md

1 Like

How did you download the .vsix file? It tries to open it with VSCode automatically for me?

Would be nice to download and save this file, just in case.

Next question is how stable is the VSCode extension API…?

I have used the download Link.

Sirs,

With the discontinuation of the extension “rebornix.ruby” in favor of “shopify.ruby-extensions-pack”
, debugging extensions via “rdebug” is no longer possible.
I researched some vscode extensions aimed at ruby ​​debugging and they caused instability in the “shopify.ruby-extensions-pack” extension.

Thomas Thomassen, was raised question about its stability and I can say that it works great, but it uses DAP to perform debugging.

From what I’ve read in other messages, the maintainers of “shopify.ruby-extensions-pack” will not support other protocols.

Based on this, I started developing the aclab-su-rdebug extension which aims to fill this gap and focusing on the SU.

The base structure is ready, but not yet functional. This week I’m going to work on a “DAP tunnel” for “rdebug”.

Do you know if there are other more mature initiatives that I could perhaps use my efforts in?

If not, I will continue with development and collaborations (development, documentation, comments, tips, anything) are welcome.
Open a ticket at https://github.com/brodao2/aclab-su-rdebug/issues, please.

Thank you for your time and consideration.
Yours faithfully,

Alan Cândido

PS: Sorry my bad english.

1 Like

Your links do not seem to be working.

Sorry. I forgot to grant access. Adjustment made.

1 Like

Does the debugger still work in Rubymine?