Very simple shape fails 3D printing manufacturability analysis

Hi there,

I created a very simple 3D model in SketchUp Free for Web. It’s basically a sheet with some thickness and 9 holes I created with the push/pull tool. See screenshot below.

In the next step, I exported the model into an STL file for 3D printing. See STL file here.

In the last step, I uploaded the STL file to 3D Hubs, but their manufacturability analysis revealed 15 intersecting faces! See screenshot of wireframe with failed checks highlighted in red here.

I tried converting my 3D model in SketchUp Free for Web into a solid group as well as creating the same shape in 15 different ways, but the manufacturability analysis still fails.

Despite my best efforts to research the issue, I cannot figure out why my SketchUp model isn’t 3D printable.

How can I create the shape shown in the above screenshot in SketchUp Free for Web such that it’s 3D printable? Which steps do I have to go through in SketchUp?

Any insights and advice are highly appreciated, since I’m working on a stainless steel enclosure for the pilot of out fireplace, and I would love to get the Fireplace going before it gets cold. :rofl:

Thank you very much,


The Original had Stray-Geometry precluding definition for a SOLID-Compo/Group (See Pic).

SKP enclosed is indeed the Solid-Compo. Should 3D-Print just fine when exported to STL

Good Luck Test Stl.skp (88.0 KB) .

Hi Dave,

Can you upload the SKP file, please?

Here you go.

Is there a face on the bottom?


If I were modeling that I would draw the square with the holes in it, extrude the face upward and, to ensure it’s printable, I’d make a component or group of it and check Entity Info to see that it reports as solid.

I just tried that . First, I created a 2D square, drew 9 circles, selected the interior surfaces of the circles and deleted them with the delete key. Next, I used the push/pull tool to give the surface some thickness. Lastly, I triple-clicked the shape, created a group and looked at the entity info below. See SKP here. The entity info looks just fine, doesn’t it?

Unfortunately, I still get 15 intersecting faces…

Thank you very much,


Hi there,

The original had Stray-Geometry precluding definition for a SOLID-Compo/Group (See Pic).

How can I see stray-geometry in SketchUp for Web in the original SKP?

Your screenshot says “solid component,” and the component has volume. Does your screenshot show the shape after you removed any stray-geometry?

Most importantly, how can I resolve/remove stray-geometry in SketchUp for Web?

Thank you very much again,


  1. Downloaded your STL because the SKP was unavailable at the time. Upon doing the Import to SKP, that’s where the Stray Lines appeared.

  2. Have looked at the recently uploaded SKP and when making it a Group, it was resolved as a SOLID.

I just looked at your Dave.skp file. I don’t see any issues with it. Unless your original file was different, I think the problems you are having are produced by the automated STL export function. It triangulates all the faces, which causes some rather tiny faces, and I think that’s what’s causing the error.

SketchUp Free has Solid Inspector built in. I don’t think you’d find any issues with your model if you checked. (model below for example has a missing face. You can see that Solid Inspector identifies this)

The only thing I could suggest would be to reduce the segments on the holes.

Mr Donley, Sir; Good hearing from you again. Regards

Getting back to the matter; this is what the imported STL appears to me.


I think yours looks different because I turned off “merge coplanar faces” so I could see exactly what the STL really looked like, as it was exported.

Alright, so I experimented with different segments for the holes… Didn’t work.

Then I thought, maybe if I subdivide the faces manually, the automated STL conversion won’t have to triangulate across such a far distance. It worked.

It passed 3DHubs checks

Here’s what it looks like in SketchUp

Here’s the STL file.
Dave24s.stl (45.8 KB)

Now, this is a really dumb workaround. I mean, it’s frustrating that it’s necessary to do this. It should just work. But basically, I just copied one of the side faces to intersect with each set of holes. I then selected all > Intersect with Model. Then I had to delete the extra faces from the center of the holes, and run solid inspector to remove the internal faces. I’m sure that doesn’t make any sense, but there you have it, that’s what I did, lol.

Hi all,

Hmm, if the issue is that STL export in SketchUp is broken/not perfect, I wonder if the SketchUp models above would pass 3dHubs’ manufacturability analysis when simply using a Pro format (as in paid) like .OBJ.

Would anybody in this forum who owns a Pro license be willing to try (see SKP here)?

Thank you,