Vanishing group/component

Third time is a charme, they say, so here it goes…

Why do groups/components disappear while working on them?

First time this happend it seemd the lines i just drew were moved to another continent, so luckely after zooming out i could find and fix the error.
Second time tho, i was inside a group i just created and while drawing the content disappeared! Even after zooming out could not find the group i just made, it wasnt in my library and the ispector also could not find the group, so i had to start all over again and this time i managed to finish and save the group.
Third time, which is a charm, i went to the forum to find out what is happening to them groups/components and how to solve this issue, and only found very old postst about it, so had to create a new post to re-open this issue.

In case you need a visual aid about the problem, here is a screenshot that does not show the missing group, since it is missing :wink:

As i was saying, i was working on a new group/component for the building to the right, which in the end would look a lot like the windowframes to the left. Managed to create the outerframe, added the vertical aligned parts and went to my second monitor to check a streetview of the building when i saw something flickering on my first monitor, and noticed the group/component was gone! zoomed out, nothing … checked my comp-library, nothing … checked the outliner, no-thing either … checked our fridge, alo nothing!?

So once again need to double draw this new group/component, butt why!?!?
Anyone knows?

Share the .skp file so we can see what you are working with. It’ll likely help us sort out what’s going on.

I think the problem started in the second half of last year…
Each time this happened it happened in different files/models and I’ve already “fixed” the window frame by recreating it so not sure if sharing would help.
Have also opened other programs that have never caused any problems until now.
Anyway, here’s the file:
SUP22_Bezonningsstudie -BGN- PROJECT.skp (5.6 MB)

I just tried to capture it on a screen video, butt ass usual no problem occurred this time ^^

At this point, since you fixed it, I don’t see anything weird. When you’ve had a component disappear have you looked for it in the In Model components? Does the definition still exist? What happens if you immediately hit Undo when the object disappears?

Yeah i know, patience is not my strongest side :wink:
But in case others have the same issue, and for future use, a solution would be nice if available.

To answer your question:
The third time it just fully disappeared and i could not find it in the component library nor with the Outliner.
Undo removed lines placed before i started to create the group/component, so unfortunately that did not work either.

It’s very weird. In 20 years of using SketchUp I’ve never experienced groups or components disappearing on their own. I wonder if there’s an extension that you have that might be involved.

Hmm, at the office i do have a lot of extentions active.
At home, where i also had this issue once, i dont use that many extentions.
Will try close those i do not use for this project, thanks for the advice/reminder!

PS in case i do manage to capture a group/component disappear while working on it, i will share it here.

1 Like

If possible share your file 2 or 3 steps before it happens. :smiley:

Problems that occur unexpectedly and without any clear steps to reproduce are certainly a challenge to solve. On the bright side, SketchUp isn’t an anesthesia machine or other critical life support device. :wink:

Like i mentioned in an earlier post, it will be tricky to capture the unexpected.
Will have to add the ‘capture screen video’ into my workflow for creating groups/components, just in case…!


managed to capture the moment a group vanishes in two screenvids(animated gif 46+26MB)
Share OneDrive: Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

both show the process starting a new group, editing the group, group disappearing, group found not hidden or moved, groupname does show in outliner but still can not be found anywhere within the model.

So … attempt 321 will be next sigh

Are you sure this indeed very strange behaviour also happens with components?
If so maybe the comonent would still be in the components panel after it vanishes…

It happens mostly when creating a group, and it did also happen while creating a component, and even when i finished a group and tried to convert it into an component.

And nope, cant find the group nor component anywhere.
In the animted gif it did show the group, with unique definition, inside the outliner, but when clicked it jumps to nothing!?
The vanishing component was not found inside the library, the outliner, the model nor in our fridge!
I also checked to see if i had hidden object and/or lines active, both where active so if it was hidden i should be able to see them.

Not sure if it could be an issue with one of many extentions that are active, they should make modelling with sketchup easier … right?

Working easier with TIG Latticeizer

and for dividing the face - s4u Divide

1 Like

Handy extentions, will try dive into them asap, but these don’t solve the issue i have with disappearing goups :stuck_out_tongue_winking_eye:
Also disabled most extentions atm to solve the issue i have with them groups/components…

Have you already tested TIG’s extension and still had problems with any groups disappearing?

Nope, havent tested it yet