V-Ray for Sketchup - Render Cannot Allocate Buffer of size 1865MB

Hi. I just installed Vray 5 on Sketchup 2022.
I tried to render an image within Sketchup and I receive the following error message:

[V-Ray] [GPU light cache] Could not allocate buffer of size 1865MB!

My GPU has 2GB of RAM and Windows is showing 4GB of shared GPU RAM.
Any ideas?

Laptop: Asus S510UN
GPU: Nvidia geforce mx150GPU 2GB (included with the laptop)
Windows 10

You can check the system requirements:


At what resolution and quality?
Have you tried to see if you can render at least one simple box?

I tried rendering at 1920px wide x 1080.
I just noticed something strange…the render always fails the first time, then succeeds the second time.
It seems to be fine after I clear Channels Data from the V-ray render window.

My laptop is an Intel i7 with 8GB RAM.

Make sure in your Nvidia control panel 3D application settings that SketchUp is set to use the Nvidia MX graphics. I have a MX 250 in my Asus ultrabook, and AFAIK it has its own memory and doesn’t share it with the CPU.

1 Like

Where is that window?