Unable to fill a simple rectange on a 'blank' background

Working on a ‘flat’ drawing, I can high-lite the face, but bucket will not fill.
It’s really simple, a rectangle. I imported an existing SU Pro that had a template called 2D, if I recall correctly but this seems crazy - there is nothing on my model in the Z direction / that I know of.

Share the .skp file so we can see what you are working with.

It’s a bit of a mess - just tring to make a 2D set- will turn it into 3D later…

DS 7 model.skp (738.0 KB)

You’re right. It is a mess.

What face are you trying to apply a material to?

I’ve turned on Sky and orbited to look up from below. You can see there are a lot of shapes without faces to apply materials to.

In most cases, where there are faces, you’ve actually applied the color to the group, not to the face inside. Examples:


By the way, it would be a good idea to fix incorrect tag usage. All edges and faces should be created AND remain untagged.
Screenshot - 5_16_2024 , 6_11_59 PM
Purging unused stuff from time to time would also be a good idea.
Screenshot - 5_16_2024 , 6_12_18 PM

Thanks - i have made respectable models in the past, I saw a select-able template in SUP 2020 ‘plan view’ - seems like a big mistake. The .skp did not import well into SU2024. I was hoping to start with ‘flat sheet’ drawings - I maybe should have also bought Autocad 2D to start the project (?) but not enough coin. I’m an old school architect scrambling toward a preliminary schematic, lol.

That isn’t necessarily a mistake. It would make it difficult to see that there are missing faces but simply orbiting around would make it possible to tell.

If it was a .skp file when you imported it, SketchUp 2024 wouldn’t have removed anything from it.

That’s kind of backward for a 3D modeler. Generally the idea is to create a 3D model of the building and then make scenes showing it in 2D to use in LayOut. All the annotation should be done in LayOut, too.

Maybe you should spend some time going through the tutorials at learn.sketchup.com before you get in deeper in this project.

Still can’t draw a simple rectangle with fill…

I don’t know why not.
rectangle

Make sure you don’t have the face style set to Wireframe. Or maybe you’re getting faces but you have the face style set to X-ray so faces are transparent.

thx a ton for your good help, will look deeper into the above suggestions.

k