Trying to move and losing it

I’m trying to move a circle. This is on a plane that isn’t exactly matching an axis (FWIW).

I’m trying to drag it, but it moves in the exact opposite direction I move my mouse. I’ve been able to move things before with the mouse and it worked correctly then. What’s going on?

What version of SketchUp ? (your profile doesn’t say.)
What graphics card (Your profile doesn’t say.)



Just for giggles, be sure you are in perspective mode. (menu Camera > Perspective.)

If it’s what I think it is, it’s a bug I reported over a decade ago and it’s still not fixed…that is an object moving in the opposite direction to the mouse when zoomed right in at certain angles. I encounter it all the time; usually when trying to move an object in empty space.
One possible way of accurately moving the circle to where you need it would be to actually draw a couple of lines on this off-axis plane that intersect at the target point…then pick up the circle by its centre and snap it there. If you don’t want those cross-hairs to mess up the outline of the circle, then either group it before you move it or draw a tiny line stub to the target point (one that will fit inside the circle without intersecting it) and delete the longer lines.

happens to me when i am detailing timber joinery, zoomed in close, lots going on… if you are moving it via numerical value, just add a negative sign ‘-’ to the number you want to move it before you type it. it should move in the correct direction then.

I ended up just typing in my coordinates. It was a little frustrating but
I got it to place where I wanted it. Yes, and it was the same situation
Mike say, zoomed in with lots of holes/dimensions.

I occasionally find that if I am offsetting a single straight line then I can’t get it to copy properly:

(note this only happens about one in twenty times for me and the following is the only common work-flow I have found it happens on…)

  • Draw a cube, draw a box on a face, push it in by a bit. Select the bottom line inside the inset [click].
  • Move the mouse upwards so that you can see the line moving up, parallel to the lower edge (can even use the arrow keys).
  • Type in a value and hit [return]
  • nothing happens.

as a work-around I have to [click] to place the line, then type in the value to get the precision I want.