TruBend Locks onto a Single Line in Object or Cmponent

I have been playing with TruBend and I like it so far, but I have ran into an issue with a model, where it doesn’t matter if I create a group or a component, and it doesn’t matter which axis I set for the object, TruBend always locks onto a particular line. I’ve


ran out of ideas, anyone?

YouTube search:

https://www.youtube.com/results?search_query=sketchup+truebend

1 Like

I tried that, after about 20 tutorials, no one had the solution.

Like I said, it doesn’t matter what axis I select, or what direction I place my component, TruBend always locks onto a particular line. And it is not the line I want to bend on.
In the attached, the arc is what I need to bend on,

From the Extension Warehouse page for the plugin:

Bends instances to a given degree, preserving the original length of the reference segment. Currently the reference segment is the bottom front of the boundingbox.

The bend is performed along the X (red) axis for the component - so make sure your instance axis line up with the bend.

Menus & Toolbars

  • Tools » TrueBend
  • Right Click » TrueBend
  • Toolbars » TrueBend

Yeah, I know I read that. But again, it doesn’t matter what axis, or direction I place my component, TruBend always locks onto this line of the component and will not allow the bend in the proper direction.


From the first tutorial in the list, it shows you that you change the axes inside the group, not outside. Have you tried this?

Attached drawing.
SpikeSquare.skp (27.5 KB)

Change the component’s axes. Read what the instructions say.

Yes, I’ve tried that.

I have. Regardless of where I place the axis, the same line gets locked.

Explode the group then make the group again

1 Like

Following your video instructions, I get this.


Got it! I moved the component off the original axis then orientated the red correctly. So all I can guess is like you said, I was only changing the default axis, not the component axis. Thank you all for your help!

1 Like

As the instructions say and I wrote …