Trouble with faces


#1

Hi everyone,

I’m a novice and I started using Sketchup for a site planning project but I have some trouble with selecting the street and sidewalk face. When I click on it the whole surface get selected, I think it’s some parallel/planar lines mistake but I spent almost two hours and can’t figure out how to solve it.
Can somebody please help me?

Model uploaded here: https://drive.google.com/open?id=1JFXUS4b1mruoHJPePrVPCE7DAwKzsMDN

Thanks!


#2

I’ve had a quick look at your model.

There are a number of things contributing to your problem.

  1. You have misunderstood the use of layers in SU. Unlike AutoCad, for example, or Photoshop, Layers in SU do NOT separate geometry. You have faces and edges with layers assigned. ALWAYS (with rare exceptions you don’t need to worry about now) keep Layer0 as the Active layer (radio button on the left of it checked - as you have it at the moment) in the Layers window. Assign layers ONLY to Groups and Components, or non-geometrical objects like dimensions, text etc, and always make sure your geometry (faces and edges) is ALL on Layer0.

  2. You have many reversed faces (showing grey-blue) in your buildings or building outlines.

  3. You have quite a number of multiple edges where there should be only one. I’ve fixed all the ones I could see. This is usually the result of trying several times to make a face close, especially when drawing with the Line tool - use the Rectangle or Arc/Pie or Circle tools to ensure you make a face, where you can do that. If you have to use the line tool for an irregular building, draw a large (usually horizontal) rectangle first, and make sure the edges you draw are on the face - watch for the On Face inference tooltip.

  4. You need to make each separate building into a component to keep its geometry separate from other buildings and your ground plane. The easiest way to do that ‘as you go’ is to draw all the connected edges and faces then triple-click any one of them to select all the new geometry, press g on the keyboard to open the Create Component dialogue, give the new component a meaningful name, then click on OK to finish component creation.

  5. I’m unclear why you have a 5m thick ground with holes in it below the buildings. I’ve deleted the lower plane for the moment, and got rid of the vertical lines round the bottoms of the buildings. It will be easy to add back if you need to later.

  6. Get into the habit when you draw of making a component out of each piece of linked geometry as you go - like a building, a ground plane, a roadway, etc. Leave NO ‘loose geometry’ in the model except while drawing a new component.

I’ve made each building into a component (some of them are only a building plan), given them a bottom face, named each uniquely B1, B2 … B16 etc, and moved all geometry onto Layer0.

I’ve put all the building components onto one layer Buildings.

I’ve made all the rest of the geometry into a single component Topography and put it on the topography layer, with all its faces and edges also on Layer0.

If you now turn off the Buildings layer, you can see that the lines defining the roads and topography don’t all join, which is one of the remaining reasons you can’t create a separate face for the topography. It’s also got holes in it where the buildings were.

See if you find it helpful to start from here, trying to fix the rest of the model, or maybe even redraw it cleanly - that’s often easier than trying to fix messy drawings.

To save file size, I’ve deleted the Google Earth image, which was making the file too large to upload here, and isn’t part of the problem. You can copy it from your original, and Edit/Paste in Place to put it back.

Here’s the revised version
tesi2 edited JWM.skp (594.8 KB)


#3

Hello John,

thank you so much for this! You’ve been very helpful!


#4

Just realised I saved your model in v2018 - can you open my upload? I’ll re-save and upload again as whatever version you use - 2016 according to your profile, and the format of the file I opened from your link, IIRC.

Here…
tesi2 edited JWM v2016.skp (584.9 KB)


#5

Yeah I’m using Sketchup Make 2016 atm but I bought a student license for Sketchup pro 2018 days ago. Thanks again for your help John, I’ll follow all your tips from now on!


#6

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.