Tray stuck in menu bar

I apparently dragged my trays into the top menu bar and can’t figure out how to get them out. I like them docked to the side. Anybo

Anybody know how to get them out of the menu bar?

Hello! Right click on the upper trays and choose “Toolbars…” Then click “Reset All”. That should bring everything to default.

No menu appears when you right click on the tab. I remember you could do that with the floating tray. I also tried resetting the workspace, with no effect.

Have you tried double clicking on the Default Tray bar?

And Window>Preferences>Workspace, Reset Workspace doesn’t work?

It should be something like this:

Trays can dock on all 4 workspace margins. To undo your current docking, first drag the tray into the workspace making it a floating tray - tug on the tray title bar area. As you drag around the tray around the central workspace you will see some buttons appear. Drag the tray to the button that points to the edge you want. See animated GIF on docking in this help section.


Reset All in View>Toolbars only restores tools to the native toolbars. If you remove tools or rearrange the tools on those native toolbars, Rest All will return them to the default state. That won’t impact the tray, though.

Window>Preferences>Workspace>Reset Workspace should, though.

Vahe - Reset All does nothing. Comes up with a warning that it I lose saved preferences. I work with keyboard shortcuts exclusively, so there is nothing to lose.
Catamounain - There is nothing to drag. Unlike a floating toolbar, this tab is in the menubar a appears fixed.
DaveR - Reset Workspace has no effect either.

Strangely, this happened yesterday, and I had another file open, so I reopened my model in that workspace and the tray stayed on the side. Saved the file with the tray on the side and opened it this morning and the tray is back to the menubar.

Open that default tray dialog. You will have a tray title bar. That is what you drag. It’s shown is the help center animation.

Edit, you first have to click on the pin on top. You will see it when hovering over the tray button to unhide the dialog. The tray will then be docked. Then you can drag on the tray title bar to make the tray floating.

1 Like

Thank you Catamountain. There is a pin when you drop down the tray as you say. Unpinned the tray and it’s floating.

I really appreciate the new tray features - just have to learn its rules. I must have hit the pin to un-dock it, then dragged it to the menu… all without meaning to.

Is there a lock feature for the trays so you can’t accidently unpin it?

No. There are three tray states - Pinned, Auto Hide and Floating. You can easily tell which state the tray is in by its behavior. Pinned is always opened, and the other two are self explanatory.

Beginning with this post I show my tray layout at that time in images and animation. I still use a mix of all three tray states - AND use a keyboard shortcut to control the visibility of the floating tray and pinned tray I don’t want to quickly slip into hiding.

The help center article on this new feature is quite good, although it seem to miss the part of setting up a keyboard shortcut.

Thanks Catamountain - just set up shortcut keys for trays.

Hi hausfxr,

Ran into the same problem myself today. Thanks for working it out! Your trick of opening the file from an open SketchUp window worked for me. After saving and reopening the file from its directory, the tray seems to be OK (floating), but if the stuck tray reappears, I’m hoping the open window trick will work again.

Have to say I’m not a fan of the tray concept. I really like being able to tear off windows as needed, as one can in the Adobe interfaces.