TIGs LayerWatcher


#1

Not sure if this is where I should be mentioning this but here I am.

I use LayerWatcher and have a model with 13 layers, LW doesn’t work with this model, works with all(?) my other models, is this a SU problem or a LW problem?


#2

Can you share the model? It’s kind of hard to tell without something to go on.


#3

Plus, please clarify what you mean by “doesn’t work”.


#4

desk7.skp (399.1 KB)
Heere it is…


#5

Click on one of the left circles doesn’t give me the warning.


#6

I have never worked for Jonny Carson:grinning:


#7

It does for me.

But I have to ask, why are you even trying to change which layer is active? You know you shouldn’t be doing that.

I’m curious why you have the geometry shown selected on a layer other than Layer 0.

Do you need some help with getting things aligned correctly? The parts don’t seem to fit real well.


#8

I also find that Layer Watcher isn’t firing the notice on this model, though I have no idea why (nothing shows in the Ruby Console). I corrected the model so that all primitives are associated with Layer0, but still no warnings…


#9


#10

I manually reloaded the main code for LayerWatcher via the Ruby Console, and suddenly it started working. This seems like there may be a bug of some sort in TIG’s loader?


#11

Interesting. I generally keep it unloaded but loaded it via the Plugin Store manager to see if it would work with the model.


#12

or the new protection modes…
I find a lot need to be manually turned on in Preferences >> Extensions, even though the code says otherwise…

john


#13

Maybe @TIG should have a look at this?


#14

Nope, at least not for me (though something about the new system may be responsible). It is turned on in my preferences and policy is set to unrestricted. I agree with Cotty. TIG himself is more sophisticated about all this stuff than I am.


#15

The latest version of LayerWatcher is signed and should work in all security policies.
However, there is a known glitch in v2016M0…
Even if an Extension is signed and set to be automatically activated when it is first installed [or it was previously activated in an earlier version] when it is newly installed from its RBZ SketchUp v2016 now sets it to be deactivated.
This means after it’s installed you need to activate it [one time only] in the native Preferences > Extensions or the SketchUcation Extensions-Manager dialog.
LayerWatcher is set up as an Extension to be loaded when installed, but unfortunately the current incarnation of v2016 switches it off and you must switch it on [once].
Because this is a mainly background plugin if easy to not realize it needs activating.

This occurs with most extensions loaded from RBZ and they need manually activating the one time - because many won’t display their menu item or toolbar etc, you have more of a clue that you need to do something to resolve it.
So bear this in mind with any extension you add to v2016M0…

Hopefully SketchUp v2016M1 will arrive one day soon and fix this particular major PITA…
It is pretty clear that it is not intended that SketchUp should work like this - but in the rush to include so many unasked for ‘features’ in the first release of v2016, someone at Trimble obviously failed to check their last minute code tweaking to ensure that they had not broken a longstanding API method, which has been used for many years to auto-activate an extension as it is first loaded…
:weary:


#16

I can’t get over clicking the circle instead of the check box, that’s why I have LW installed.

Wow! Probably because LW wasn’t working as I expected.

No thanks, the desk is already built.


#17

(off topic) Is there an easy/quick way to find the primitives that are not associated with layer0.


#18

The easiest thing to do is run TIG’s Default Layer Geometry and fix it rather than looking for the geometry that isn’t on Layer 0


#19

I’m with Dave. What you really want is to correct the bad layer associations, not to find the guilty entities. Finding them just leaves you still needing to do something about them! There are several other plugins available that do about the same thing as the TIG one Dave mentioned (including one of mine).


#20

Thanks, I ran TIG’s Default Layer Geometry and it moved all the dimensions to layer0, which after thinking about it, is logical and easy to ‘fix’.