The other day I read an article where the phrase “block” was used for either a group or a component instance. I almost absolutely certain this was in the official documentation, SketchUp blog or perhaps even in the UI of an extension made by the SketchUp team (such as Dynamic Components) but I just can’t remember where. Has anyone else seen this use of this word?
I very often find myself writing “group/component” both when commenting my own code and when documenting my extensions. A phrase that refers to both could be quite useful. I’ve sometimes used the phrase “instance” for code comments and variable names since the API method for adding both groups and component instances is called add_instance. However the SketchUp UI refers to both components and groups simply as Components (View > Component Edit, Model Info > Components > Component Axes). Technically a group is a component but the phrase usually refers to a component that is not a group.
Is there any preferred term to use when you explicitly mean both groups and components?