I think we all know that Groups are basically like a subclass of ComponentInstance but still not really etc etc.
Very often code, as well as the end user, makes no difference between a Group and a ComponentInstance, but there is no common superclass or other name given in the API to refer to them both. Often they are referred to as instances or containers.
I’m thinking I’ll refer to something that is either a Group, ComponentInstance or an Image as an instance, and a something that is either a Group or ComponentInstance as a container when naming variables and parameters. I’ve seen these terms being used interchangeably but it might be useful to make a difference between the two.
In a very technical sense you could argue an Image is also a container as it contains a face and 4 edges, but in a more practical sense this is an implementation detail, while the contained entities is the essence of a group/component.
Thoughts on this?