Textures and Warehouse elements not loading?

Have been using SketchUp for Schools through GSuite for a few years now with no issues. Last week one pupil logged on and found that textures such as grass, tiles, carpet were appearing as flat colours. When getting an item from the warehouse, the mouse reacts as though something is attached (changes appearance) and the text at the bottom of the screen says click to place (or whatever it usually says) but there is no object there - we cannot see it.
Can someone help? It is only one student having this issue and it doesn’t matter what Chromebook I use for her, it keeps happening.

It sounds like the student has selected a style that shows Shaded not Shaded with textures. Did you check that?

What elements are they trying to get from the Warehouse? Can you get and share their SketchUp file so we can see what might be going on?

Thanks for your quick response - my understanding of SketchUp is quite basic.

I’ve just tried to change the shaded/with textures but it makes no difference on her account (I tried it first on mine and it does change).

I’ll try to get the file.

1 Like

I’ll make another guess while hoping to see her file. Perhaps she’s making her model huge–much bigger than normal real world dimensions. This would result in textures looking like solid colors because they are sized for real world dimensions. It would also mean that components she downloads from the Warehouse wouldn’t appear because they are microscopic relative to her model.

sketchuptryout.skp (1.2 MB)

This is the file. I’ve just tried it on my account and the textures and items from warehouse still don’t work. It was during a lesson where the pupils were learning to use SketchUp so we were just searching for ‘plant’ in the warehouse. She had selected the same one as me so I knew that file worked.

I’ve just tried starting a new project on her account which seems to work fine - must be an error with this specific project.

It’s a size issue. She’s made her house about a mile wide.
Screenshot - 3_8_2023 , 8_44_18 AM

If you zoom in really close to the transparent wall of the house you can see she’s applied a fence texture to it.

1 Like

:smile: Oh! What you’ve said makes complete sense for both textures and components. I had no idea she had made it so big!
As I said, they were all learning how to use the tools - make shapes and add bits on. This will be a lesson learnt for all of us - especially me.
Thank you so much for identifying our error.

1 Like

It’s not an unusual thing for new students to model at incorrect sizes. They provide a scale figure in the startup template that the user will hopefully use as a reference. If you look near the origin, you should find Katherine Johnson standing there.

How old are your students? Might be best to give them a lesson in using the Measurements window to get an idea of how large things are as they are modeling and to teach them to use real world dimensions as they model.

FWIW, the chair she imported from the 3D Warehouse is inside the house but laying on its side and half embedded in the floor.

1 Like

Yes, I showed them Katherine and we talked about how when they make their building they can use her to think about how big it needs to be. :+1:t3: I think this was just a first time error.
My pupils are 9/10yrs old. We make shapes at first and learn how to move about the models. Then they create art galleries to display items from favourite artists. It’s only 5 lessons so it’s a bit of a whistlestop experience so they can see how 3D modelling works and try their skills with a program which is different to publishing/word processing/coding.
I’ll definitely factor in some measurement work too - thanks for the tip.

1 Like