Surfaces with more than one area without lines defining a different shape


#1

I am working on a complex model and am having problems with what seems to be overlapping/hidden surfaces.

I have a wall of a house. The wall is made up of just one shape (a planar rectangle). When I select this shape only part of the shape is selected. The other part, with no line delineating a different shape, is not highlighted.

I have experienced this in the past. It is a pain. What is it and how do I fix it?


#2

Here is an image of the wall I am talking about


#3

There might be a hidden line splitting the face.
View > Hidden Geometry > ON to see it.
Try Erasing it.
If the two faces merge, that’s good, but if they vanish use Undo, and see what’s skewing the two faces to make them non-coplanar…


#4

I did use show hidden geometry and there wasn’t anything there. I get this more often than I’d like to admit. Just a pain. Are there other fixes?


#5

If you copy a problem area into a new file, is it still bad? If so, could you upload a small test file for us to look at?


#6

Copying the wall just copies the problem. Good idea thought. I already tried that.


#7

I am also having an issue where I have a line that is in bits. I erase that line to draw a line that is one piece and the new line is also segmented the exact same way as before I tried the fix.

Similar issue. Phantom stuff.


#8

Another thought… :bulb:
Have you incorrectly used Layers ?
ALL edges and faces should be assigned Layer0.
Always leave Layer0 as your current layer.
You can select a collection of geometry and make it into a group or component, and assign another Layer to that.
Then switching that Layer on/off controls its visibility.
SketchUp Layers are NOT like CAD Layers, they do NOT separate geometry, and faces need their edges, even when they are are incorrectly assigned to different Layers…

I you have hidden geometry visible AND ALL layers ON can you see the dividing edge ?
It has to be there to split the face into two pieces…
But if it’s on an OFF Layer it will not be visible, but it will still split the visible edges…


#9

TIG, now that is a good idea! I’ll check that out. I had imported geometry in a .dwg this could be the source of my issues.

Thanks.