SU only give approx measures


#1

I create a model and the precision is 0.xxxxxxmm (maybe overkill). I save it and reopen it with the same precision. If export it to a STL file and import that STL file or one that I dnld when I measure a distance it displays ~Xmm.
It will snap to Xmm but anywhere in between X & Y it is ~Xmm or ~Ymm. Even if I save the imported STL file as an SKP file, when I reopen it, the precision is still 0mm.
How do I get it to show the std precision for imported files?


#2

As I mentioned in your other thread, .stl files aren’t great imports. They pretty much ignore units and are just what they are.
But you could try unticking snap to in the units of your model.


#3

→ Related thread

Apart from that, it’s not the precision of coordinates that you set, but the specific model’s properties for how precisely numbers are displayed.

Your model does not become less precise when you import it, you are just importing it into a new model that has different model properties. If you want model properties (Model Info, Styles…) to be applied to all new models, you need to choose a different template, or save a new template.


#4

Yeah I wasn’t sure from the description if it was being imported back into the same model with the precision set.

But we all know that SU is far more accurate than so many people believe.


#5

UNITS
the problem was my old mind couldn’t remember where UNITS was

a GREAT answer would have been
WINDOWS/MODEL INFO/UNITS

thx


#6

A great question would have been, how do I adjust the accuracy of my model.


#7

that does not describe the issue I was experiencing.
PLONK


#8

In the “other” thread I quoted verbatim the stl file format at least as Wikipedia thinks it is.
It does not have units. However some authors will include units and color, but the they are not “real” stl format per definition.
For this very reason the SU stl importer ask you pick units, some others will include that in their setup settings ie Netfabb. I do not recall seeing any " standard " precision for imported files. The precision you are discussing is display precision. Make sure in you template you use decimal not fractional.


#9

Some people really don’t understand the nature of forums or the help and information freely given.